# Error when i change from http to https

**URL:** <https://discourse.openondemand.org/t/error-when-i-change-from-http-to-https/3991>\
**Category:** Get Help\
**Tags:** question\
**Created:** [January 28, 2025, 8:50am UTC](https://discourse.openondemand.org/t/error-when-i-change-from-http-to-https/3991 "2025-01-28T08:50:42Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![toto](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/toto/32/2515_2.png) [@toto](https://discourse.openondemand.org/u/toto)\
**Post date:** [January 28, 2025, 8:50am UTC](https://discourse.openondemand.org/t/error-when-i-change-from-http-to-https/3991/1 "2025-01-28T08:50:42Z")

</div>

Hi,  
I’ve successfully configured ood without ssl. Now i want to change from http to https. What i did in ood\_portal.yml is  
add this section at the top

```auto
ssl:
  - 'SSLCertificateFile "/etc/pki/tls/certs/full_chain.pem"'
  - 'SSLCertificateKeyFile "/etc/pki/tls/private/server.key"'

```

add this section under dex:

```auto
dex:
  # Default based on if ssl key for ood-portal-generator is defined
  ssl: true
  # Only used if SSL is disabled
  http_port: "5556"
  # Only used if SSL is enabled
  https_port: "5554"
  tls_cert: "/etc/pki/tls/certs/full_chain.pem"
  tls_key: "/etc/pki/tls/private/server.key"

```

After this i restart ondemand-dex and httpd but I can’t open default page and in error.log show

```auto
[Tue Jan 28 15:46:11.989635 2025] [auth_openidc:warn] [pid 2123787:tid 140096623929088] [client 10.128.1.10:43060] oidc_clean_expired_state_cookies: state (mod_auth_openidc_state_S3XEss45S7ZOYXyrvsh9qFLzYlY) has expired (original_url=http://raptor.med.cmu.ac.th:9000/pun/sys/dashboard)

```

I tried to check port on dex but it still using 5556 which is http.

```auto
tcp LISTEN 0 2048 127.0.0.1:5556 0.0.0.0:* users:(("ondemand-dex",pid=2123687,fd=9))

```

Please help

Thanks

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [February 3, 2025, 6:50pm UTC](https://discourse.openondemand.org/t/error-when-i-change-from-http-to-https/3991/2 "2025-02-03T18:50:40Z")

</div>

Hi, sorry for the delay in response.

You may have to regenereate the configurations if you’ve reconfigured `ood_portal.yml`. Bouncing httpd should do this, but after you bounce httpd, you likely also need to bonce the `ondemand-dex` systemd unit.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex015/uploads/osc/original/2X/b/bae70bd0ed39a3ae769c2108155f4cb3e9da8385.png) [@system](https://discourse.openondemand.org/u/system)\
**Post date:** [August 2, 2025, 6:51pm UTC](https://discourse.openondemand.org/t/error-when-i-change-from-http-to-https/3991/3 "2025-08-02T18:51:30Z")

</div>

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.
