# Internal Server Error After Fresh Install

**URL:** <https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937>\
**Category:** Get Help\
**Created:** [February 25, 2022, 7:58pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937 "2022-02-25T19:58:46Z")\
**Posts on this page:** 8\
**Page:** 3

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [March 14, 2022, 3:31pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/41 "2022-03-14T15:31:48Z")

</div>

Sorry. What I’m looking for here is - how is dex responding? Clearly there’s a communication breakdown between apache and dex. Navigate to dex through a web browser and/or curl to see how it’s responding.

You could be running into this issue.

> [@Dex and ssl certs](https://discourse.openondemand.org/t/dex-and-ssl-certs/1532/4):
>
> Yeah this just bit me, unless I cat’d the fullchain of a letsencrypt cert into the cert file itself I was left with dex erroring on the generic: http: TLS handshake error from \<ip address\>:58758: local error: tls: bad record MAC Is this an upstream Dex issue?

---

<div class="post-metadata">

**Author:** ![jshleap](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jshleap/32/998_2.png) [@jshleap](https://discourse.openondemand.org/u/jshleap)\
**Post date:** [March 14, 2022, 3:44pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/42 "2022-03-14T15:44:56Z")

</div>

Sorry, not sure I follow. This is the first time I use dex, so not sure what you mean by navigate to it, when I cannot browse it. Curling I can do, but what do you want me to curl? I am sure I am missing something very simple here, but I dont see it. I checked the issue you sent, and I copied the certificates to anchors, and did an update-ca-trust, and did not change a thing, same internal server error.

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [March 14, 2022, 3:50pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/43 "2022-03-14T15:50:59Z")

</div>

You have the right url set in apache. Navigate here in a web browser. The idea here is confirming we can connect to it and SSL is all setup right. `curl` and a webbroswser will both complain if something is a miss.

```auto
 OIDCProviderMetadataURL https://sandstone.sharcnet.ca:5554/.well-known/openid-configuration

```

What is apache error are you still seeing @jshleap? If you have this config and apache has been restarted then it should start to respond to it or in the very least throw a different message.

@brad.traver what’s going on with your installation? What’s the latest iss you’re seeing.

---

<div class="post-metadata">

**Author:** ![brad.traver](https://avatars.discourse-cdn.com/v4/letter/b/82dd89/32.png) [@brad.traver](https://discourse.openondemand.org/u/brad.traver)\
**Post date:** [March 14, 2022, 4:05pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/44 "2022-03-14T16:05:22Z")

</div>

Jeff,

My Dex config file still isn’t updating. I removed all the commented out lines from the Dex section of ood\_portal.yml. After regenerating the files and restarting the services, the Dex config file still hasn’t changed. It’s still missing the connector section where I have LDAP configured.

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [March 14, 2022, 4:10pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/45 "2022-03-14T16:10:24Z")

</div>

OK I’d guess you still have some formatting issue. I’d suggest starting over from a fresh file or open `ood_portal.yml` up in maybe `vim` or similar to see if there are any funny characters (committing it to git works too).

If you remove `/etc/ood/config/dex/config.yaml` - does that do anything? Also be sure to look at the output of `update_ood_portal` it’s likely to give you clues about what’s going on. Maybe you can’t write to that file and/or location anymore?

---

<div class="post-metadata">

**Author:** ![brad.traver](https://avatars.discourse-cdn.com/v4/letter/b/82dd89/32.png) [@brad.traver](https://discourse.openondemand.org/u/brad.traver)\
**Post date:** [March 14, 2022, 7:42pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/46 "2022-03-14T19:42:16Z")

</div>

I tried removing the Dex config file and regenerating the files but that didn’t work. I’m going to uninstall and reinstall OOD so I can start with a fresh config.

---

<div class="post-metadata">

**Author:** ![brad.traver](https://avatars.discourse-cdn.com/v4/letter/b/82dd89/32.png) [@brad.traver](https://discourse.openondemand.org/u/brad.traver)\
**Post date:** [March 14, 2022, 9:00pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/47 "2022-03-14T21:00:47Z")

</div>

After an uninstall and reinstall, the LDAP settings are now being applied. It’s not totally working yet as I need to adjust some of the LDAP attributes.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex015/uploads/osc/original/2X/b/bae70bd0ed39a3ae769c2108155f4cb3e9da8385.png) [@system](https://discourse.openondemand.org/u/system)\
**Post date:** [September 10, 2022, 9:01pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937/48 "2022-09-10T21:01:22Z")

</div>

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

[Previous page](https://discourse.openondemand.org/t/internal-server-error-after-fresh-install/1937.md?page=2)
