# Internal server error after installing on RHEL8

**URL:** <https://discourse.openondemand.org/t/internal-server-error-after-installing-on-rhel8/2123>\
**Category:** Get Help\
**Created:** [June 17, 2022, 8:44pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-installing-on-rhel8/2123 "2022-06-17T20:44:00Z")\
**Posts on this page:** 1\
**Showing post:** 17

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [June 24, 2022, 7:04pm UTC](https://discourse.openondemand.org/t/internal-server-error-after-installing-on-rhel8/2123/17 "2022-06-24T19:04:50Z")

</div>

Very good! Progress!

You could look at `systemctl status ondemand-dex` or `journalctl -u ondemand-dex` but I don’t believe it’ll say anything meaningful. That is, unless you’re unable to bind/connect to your LDAP at all. That could be one issue. That you’re unable to query LDAP at all. I don’t know how dex would respond to the user with this info.

If you can correctly bind - then I’m guessing this is the documentation you’re looking for. My guess is your search/filter/query isn’t quite right.

[https://dexidp.io/docs/connectors/ldap/](https://dexidp.io/docs/connectors/ldap/)

There’s also this note that I left for myself around `ldapsearch` and different ways to debug you’re query. I get the feeling that you’ll need to experiment with `ldapsearch` to refine your settings.

> [@Having issues setting up LDAP/Active Directory auth](https://discourse.openondemand.org/t/having-issues-setting-up-ldap-active-directory-auth/675/3):
>
> For reference (my own as much as anyone else’s’), here’s the ldapsearch translation of that AuthLDAPURL. “ldap://ldap.domain.local:389/OU=Users,DC=domain,DC=local?sAMAccountName”’ ldapsearch -W -h "ldap.domain.local" -b "OU=Users,DC=domain,DC=local" cn=test.user sAMAccountName If I do something similar for myself, I can find myself in our LDAP. [johrstrom@host ~]$ ldapsearch -x -h "host" -b "ou=People,dc=osc,dc=edu" cn=johrstrom uid # extended LDIF # # LDAPv3 # base \<ou=People,dc=osc,dc=edu\> …

---

_[View the full topic](https://discourse.openondemand.org/t/internal-server-error-after-installing-on-rhel8/2123)._
