Issues running vmd on ood on cluster

Are you seeing headers in the VMD app now or does it still appear the same?

Still appears exactly the same as before.

I have a question about behaviour of the VMD setup on ood. At this point I am under the impression that once VMD launches that the VMD windows are fixed on the screen and not able to be moved? Also, as the image above shows, part of the right window is cut off. Is there a way to fix that?

To reiterate, the full desktop works just fine and doing some searching we see the following which seems to be related?

Window Manager (xfwm4) for xfce4 failing - #7 by jeff.ohrstrom.

Are you still getting the following errors like you posted back in Sept?:

xfce4-terminal -e vmd -T ‘VMD Terminal’ --disable-server
Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined
/home/wew/ondemand/data/sys/dashboard/batch_connect/dev/bc_osc_vmd/output/58252e11-83b9-429c-94fb-c9961e74abd0/script.sh: line 30: 1632966 Trace/breakpoint trap (core dumped) xfsettingsd --sm-client-disable

If so, looking at the VMD script here: bc_osc_vmd/script.sh.erb at master · OSC/bc_osc_vmd · GitHub maybe it’s an issue with your virtualgl / vglrun setup?

Can you test the following to see if this works?

  1. Launch your plain desktop app that you got working a few weeks ago
  2. open a terminal within it
  3. do “module load virtualgl”
  4. then “vglrun glxgears”

See if that works ok. If not, you likely have an issue with your VirtualGL setup. See this page for more help on that:
https://wiki.archlinux.org/title/VirtualGL

doing just glxgears works but with vglrun we get a display error.

I think we are narrowing into more of the issue now. If you look at the commands in the VMD script I linked to, they include:

module load xalt/latest intel/16.0.3 virtualgl vmd/1.9.4
xfce4-terminal -e “vglrun vmd” -T “VMD Terminal” --disable-server

If vglrun isn’t working at all, I"m surprised that vmd is launching at all. I think you might need to look at your virtualgl install and debug it a bit. The page I linked to above has some good initial debugging tips.

FYI potential fix for this:

  1. Make sure /run/user/UID is being created. E.g. in slurm prolog:

function prolog_xdg_setup () {
local XDG_RUNTIME_DIR=/run/user/$(id -u $SLURM_JOB_USER)
[[ -d $XDG_RUNTIME_DIR ]] || mkdir $XDG_RUNTIME_DIR
local PGROUP=$(id -ng $SLURM_JOB_USER)
chown $SLURM_JOB_USER:$PGROUP $XDG_RUNTIME_DIR
chmod 0700 $XDG_RUNTIME_DIR
}

  1. Make sure you manually execute dbus before xfwm4 in /var/www/ood/apps/sys/bc_osc_vmd/template/script.sh.erb and manually set VGL_DISPLAY=$DISPLAY

module purge
module load vmd

cd “${HOME}”

eval $(dbus-launch --sh-syntax)

(
export SEND_256_COLORS_TO_REMOTE=1
export XDG_CONFIG_HOME="<%= session.staged_root.join(“config”) %>"
export XDG_DATA_HOME="<%= session.staged_root.join(“share”) %>"
export XDG_CACHE_HOME="$(mktemp -d)"
set -x
xfwm4 --compositor=off --sm-client-disable
xsetroot -solid “#D3D3D3
xfsettingsd --sm-client-disable
xfce4-panel --sm-client-disable
)&
set -x
export VGL_DISPLAY=$DISPLAY
xfce4-terminal -e “vglrun vmd” -T “VMD Terminal” --disable-server