# Large file/directory downloads fail with timeout or network error

**URL:** https://discourse.openondemand.org/t/large-file-directory-downloads-fail-with-timeout-or-network-error/4946
**Category:** Get Help
**Created:** [August 11, 2026, 9:39am UTC](https://discourse.openondemand.org/t/large-file-directory-downloads-fail-with-timeout-or-network-error/4946 "2026-08-11T09:39:29Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![jasonbuechler](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jasonbuechler/32/302_2.png) [@jasonbuechler](https://discourse.openondemand.org/u/jasonbuechler)
#### Post date: [August 11, 2026, 7:16pm UTC](https://discourse.openondemand.org/t/large-file-directory-downloads-fail-with-timeout-or-network-error/4946/2 "2026-08-11T19:16:32Z")

</div>

I have seen very similar behavior, and never resolved it but mentioned what I’d found here:

> [@File manager errors: Large uploads (to lustre fs) appear to fail](https://discourse.openondemand.org/t/file-manager-errors-large-uploads-to-lustre-fs-appear-to-fail/4735):
>
> environment: OOD 4.0.8 unpopulated dev system hyper-v VM selinux disabled cgroupsv2 enabled no upload-limit mods in /etc/ood/config/apps/dashboard/env I’m seeing an issue that seems very similar to [this March 2024 report](https://discourse.openondemand.org/t/large-uploads-failing-ood-3-0-1/3315) about large uploads failing with OOD 3.0.1. However my “large” uploads are only ~1.5GB, and the problem seems isolated to uploading to our /scratch fs (which is an NFS export of a bare metal lustre mount to our Vast system). About the error: filemanager’s upload dialog ev…

Frustratingly, the cutoff for what filesize was too big was never written in stone – sometimes a given ~1.5gb file would upload with success, other times it would (appear to) fail.

I had a theory that it had something to do with my /tmp or /var (lvm-)filesystem filling up since I discovered a given upload will eat up space on both. This didn’t seem to be the root issue for me (at least with the brief investigation I did) but maybe worth checking if it’s the case for you: [PSA: File Manager uploads use both /var and /tmp space](https://discourse.openondemand.org/t/psa-file-manager-uploads-use-both-var-and-tmp-space/4736)

My example watch-script is admittedly hard to read but the gist of it is a single upload temporarily stores _three_ copies, like:

- /proc/1386416/fd/8 =\> / **var** /tmp/ondemand-nginx/USERID/client\_body/0000000001 (deleted)
- /proc/1795862/fd/10 =\> / **tmp** /PassengerTeeInput-1l86ohu (deleted)
- / **tmp** /RackMultipart20260219-1795862-wimnh4.zip

---

_[View the full topic](https://discourse.openondemand.org/t/large-file-directory-downloads-fail-with-timeout-or-network-error/4946)._
