# Need help, tried everything- Ondemand - Interactive Apps Schedule Desktop fails Auth

**URL:** <https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365>\
**Category:** Get Help\
**Tags:** question\
**Created:** [July 15, 2025, 6:21pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365 "2025-07-15T18:21:21Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![plthomas1](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/plthomas1/32/2834_2.png) [@plthomas1](https://discourse.openondemand.org/u/plthomas1)\
**Post date:** [July 15, 2025, 6:21pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/1 "2025-07-15T18:21:21Z")

</div>

Warning: Permanently added ‘reactor.arc.kent.edu’ (ED25519) to the list of known hosts.  
plthomas@reactor.arc.kent.edu: Permission denied (publickey,password).

Ssh works from Shell access, just have to add password.

Interactive Apps Schedule Desktop fails Auth, fails, but does not ask for password.

# /etc/ood/config/clusters.d/arc.yml

* * *

v2:  
metadata:  
title: “arc”  
url: “[https://ondemand-1.arc.kent.edu](https://ondemand-1.arc.kent.edu)”  
hidden: false  
login:  
host: “reactor.arc.kent.edu”  
job:  
adapter: “slurm”  
cluster: “arc”  
bin: “/usr/bin”  
conf: “/etc/slurm/slurm.conf”  
ssh\_hosts: “reactor.arc.kent.edu”  
submit\_host: “reactor.arc.kent.edu”  
strict\_host\_checking: false  
bin\_overrides:  
sbatch: “/usr/local/bin/sbatch\_wrapper”  
# squeue: “”  
# scontrol: “”  
# scancel: “”  
copy\_environment: false

batch\_connect:  
basic:  
script\_wrapper: |  
module purge  
%s  
set\_host: “host=$(hostname -A | awk ‘{print $1}’)”  
vnc:  
script\_wrapper: |  
module purge  
export PATH=“/opt/TurboVNC/bin:$PATH”  
export WEBSOCKIFY\_CMD=“/usr/local/bin/websockify”  
%s  
set\_host: “host=$(hostname -A | awk ‘{print $1}’)”

Logfile info.  
n /tmp/sbatch.log the final line is

INFO:sh.command:\<Command ‘/usr/bin/ssh myusername@head -oBatchMode=yes /opt/slurm/bin/sbatch -D /home/myusername/ondemand/data/sys/dashboard/batch\_connect/sys/bc\_desktop/arc/output/60cd0c36-db12-4ac3-8b95-111c5def3e17 -J sys/dashboard/sys/bc\_desktop/arc -o /home/myusername/ondemand/data/sys/dashboard/batch\_connect/sys/bc\_desktop/arc/output/60cd0c36-db12-4ac3-8b95-111c5def3e17/output.log -t 01:00:00 --export NONE -N 1 --parsable -M arc --export=THE\_ANSWER=42’, pid 128862\>: process started  
INFO:root:ssh: Could not resolve hostname head: Temporary failure in name resolution

---

<div class="post-metadata">

**Author:** ![travert](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/travert/32/3074_2.png) [@travert](https://discourse.openondemand.org/u/travert)\
**Post date:** [July 15, 2025, 10:19pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/2 "2025-07-15T22:19:56Z")

</div>

Hello and welcome.

Looking at the log entry I see `head` is not the correct hostname but it is trying to login to that host to run the command.

Do you have a `submit.yml` for the app you can share? [4. Custom Job Submission — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/latest/enable-desktops/custom-job-submission.html)

---

<div class="post-metadata">

**Author:** ![plthomas1](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/plthomas1/32/2834_2.png) [@plthomas1](https://discourse.openondemand.org/u/plthomas1)\
**Post date:** [July 16, 2025, 2:27am UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/3 "2025-07-16T02:27:57Z")

</div>

Thank you so much for responding.  
Where would I find the submit.yml?

Phil

---

<div class="post-metadata">

**Author:** ![plthomas1](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/plthomas1/32/2834_2.png) [@plthomas1](https://discourse.openondemand.org/u/plthomas1)\
**Post date:** [July 16, 2025, 2:57am UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/4 "2025-07-16T02:57:29Z")

</div>

> [@plthomas1](#):
>
> submit.yml?

I found the doc, that talked about submit.yml

> **[submit.yml.erb — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/develop/reference/files/submit-yml-erb.html#submit-yml-erb)**

Document does not give location to find File, I did update  
/etc/ood/config/clusters.d/

Added this.  
basic:  
header: “#!/bin/bash”  
vnc:  
header: “#!/bin/bash”

Still get error. changes listed below.

# /etc/ood/config/clusters.d/arc.yml

* * *

v2:  
metadata:  
title: “arc”  
url: “[https://ondemand-1.arc.kent.edu](https://ondemand-1.arc.kent.edu)”  
hidden: false  
login:  
host: “reactor.arc.kent.edu”  
job:  
adapter: “slurm”  
cluster: “arc”  
bin: “/usr/bin”  
conf: “/etc/slurm/slurm.conf”  
ssh\_hosts: “reactor.arc.kent.edu”  
submit\_host: “reactor.arc.kent.edu”  
strict\_host\_checking: false  
bin\_overrides:  
sbatch: “/usr/local/bin/sbatch\_wrapper”  
# squeue: “”  
# scontrol: “”  
# scancel: “”  
copy\_environment: false

batch\_connect:  
basic:  
script\_wrapper: |  
module purge  
%s  
set\_host: “host=$(hostname -A | awk ‘{print $1}’)”  
header: “#!/bin/bash”  
vnc:  
script\_wrapper: |  
module purge  
export PATH=“/opt/TurboVNC/bin:$PATH”  
export WEBSOCKIFY\_CMD=“/usr/local/bin/websockify”  
%s  
set\_host: “host=$(hostname -A | awk ‘{print $1}’)”  
header: “#!/bin/bash”

---

<div class="post-metadata">

**Author:** ![travert](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/travert/32/3074_2.png) [@travert](https://discourse.openondemand.org/u/travert)\
**Post date:** [July 16, 2025, 6:27pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/5 "2025-07-16T18:27:41Z")

</div>

Let’s start from the beginning as there’s a few things here we need to address to get you all setup. I’ve got some steps below to work through and relevant doc sections to help guide you where needed.

Also, just an FYI for the future, formatting your configs in discourse using markdown helps a ton for us in debugging 🙂

Ok so first, you need to add a `cluster.yml` file to the app itself so that it knows what cluster to use:

> **[2. Add a Cluster — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/latest/enable-desktops/add-cluster.html)**

Make sure to follow that warning and set the `cluster` attribute to `arc` as that looks to be the name of the cluster in your `/etc/ood/config/clusters.d/` directory.

Then, within that app specific cluster config file, you need to set the `submit` option for the `submit.yml.erb` file you intend to use for the desktops: [4. Custom Job Submission — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/latest/enable-desktops/custom-job-submission.html)

Lastly, the `submit.yml` you shared looks to have some typos such as `basic:`. I’d recommend parsing that  
file more closely and ensuring you don’t have any little hiccups like that by using the config reference for the `submit.yml`: [submit.yml.erb — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/latest/reference/files/submit-yml-erb.html)

In summary, you need to add a cluster file to the app itself letting the app know which cluster you are submitting to, add a `submit` option to that app cluster file with the path to the `submit.yml` you are using for the desktops, ensure the typos in the `submit.yml` are addressed, and that should be enough for the moment to iterate on.

I did also just notice in the original post you mentioned that your ssh works but you “just have to add password”. I am starting to wonder if this will be another problem as you will need to ensure you are allowing passwordless ssh for ood to work, otherwise it can’t login to run the commands to submit jobs and will fail silently.

---

<div class="post-metadata">

**Author:** ![plthomas1](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/plthomas1/32/2834_2.png) [@plthomas1](https://discourse.openondemand.org/u/plthomas1)\
**Post date:** [July 17, 2025, 6:34pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/6 "2025-07-17T18:34:32Z")

</div>

Thank you for your advise,  
Working on getting discourse installed, don’t do much programming.

I was under the impression you would not need the submit.yml, if you were going to do the global version in the clusters.d/arc.yml.

I created the submit.yml.erb file

/etc/ood/config/apps/bc\_desktop/submit  
#a simple script.yml.erb file  
script:  
native:  
- “-n”  
batch\_connect:  
template: “vnc”

-----You comment on password issue is still true,  
Not sure why its trying to use my Plthomas account with no password.  
I installed the munge stuff on both servers,  
We just tried set up the ssh key auth between servers.

I log into web portal using campus AD, --yea  
When I start a Desktop Job, should it not be using the server to server auth connections to start job on cluster node, and not my auth

I just seems to want to connect using plthomas with no password.

---

<div class="post-metadata">

**Author:** ![travert](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/travert/32/3074_2.png) [@travert](https://discourse.openondemand.org/u/travert)\
**Post date:** [July 17, 2025, 9:56pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/7 "2025-07-17T21:56:07Z")

</div>

You can set the submit options _globally_ in the cluster file, I didn’t realize that was what you were going for, sorry about that.

> **[submit.yml.erb — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/latest/reference/files/submit-yml-erb.html#setting-batch-connect-options-globally)**

But later on if you add more apps you are going to want to follow the previous steps to make your configs modular. I’d strongly recommend a modular setup rather than global options though, even when starting out.

> [@plthomas1](#):
>
> When I start a Desktop Job, should it not be using the server to server auth connections to start job on cluster node, and not my auth
> 
> I just seems to want to connect using plthomas with no password.

OOD is running _your_ job on the cluster, so it is using _your system account_ to do this. Munge is not a factor in this. When you submit jobs, your system account on the OS is ssh-ing to the cluster to issue commands first, that’s why there can’t be a password in the way or OOD just fails when the SSH password prompt is issued. This is done for many reasons with the most obvious being resource accounting and also things like file permission/ownership. When the job is ready the URL is passed back and you can simply click the Connect button to login to your interactive app.

Hopefully this is making more sense and helping with progress. We do have a page that goes over the architecture of this from a very high level that might help with understanding: [Architecture — Open OnDemand 4.0.0 documentation](https://osc.github.io/ood-documentation/latest/architecture.html)

---

<div class="post-metadata">

**Author:** ![plthomas1](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/plthomas1/32/2834_2.png) [@plthomas1](https://discourse.openondemand.org/u/plthomas1)\
**Post date:** [July 18, 2025, 1:14pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/8 "2025-07-18T13:14:54Z")

</div>

This is probably a stupid question, I seem to have a lot of them.

How to you get on demand web portal to pass the user name and password to server node?

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [July 22, 2025, 2:58pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/9 "2025-07-22T14:58:47Z")

</div>

@plthomas1 if you’re still having issues getting the desktop to run, please post the `output.log` from the job for us to inspect. It should have some output on why it’s failing.

---

<div class="post-metadata">

**Author:** ![plthomas1](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/plthomas1/32/2834_2.png) [@plthomas1](https://discourse.openondemand.org/u/plthomas1)\
**Post date:** [July 24, 2025, 11:22pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/10 "2025-07-24T23:22:36Z")

</div>

We have fixed this issue, thanks so much  
More and better issues in anther post.

---

<div class="post-metadata">

**Author:** ![jemartinezcomillas](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jemartinezcomillas/32/3150_2.png) [@jemartinezcomillas](https://discourse.openondemand.org/u/jemartinezcomillas)\
**Post date:** [November 19, 2025, 9:38am UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/11 "2025-11-19T09:38:21Z")

</div>

Could you share your solution with me? I’m trying to create an interactive app, one that performs a Slurm job and another to open a Jupyter machine, but both give me the error ‘No ED25519 host key is known for ’

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [November 19, 2025, 1:34pm UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/12 "2025-11-19T13:34:41Z")

</div>

Hi and welcome @jemartinezcomillas!

I’d say open a new topic then we can help you there. At a glance this error:

> [@jemartinezcomillas](#):
>
> ‘No ED25519 host key is known for ’

Seems to indicate you’re using a `submit_host` to submit your jobs and you can’t ssh to it because of keys. We (at OSC) use `HostBasedAuthentication` so ssh works pretty seamlessly from one machine to another.

---

<div class="post-metadata">

**Author:** ![jemartinezcomillas](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jemartinezcomillas/32/3150_2.png) [@jemartinezcomillas](https://discourse.openondemand.org/u/jemartinezcomillas)\
**Post date:** [November 21, 2025, 9:57am UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/13 "2025-11-21T09:57:13Z")

</div>

thanks for the welcome. and thanks for the solution.

i seem that i had a bad configuration in my “/etc/ood/config/clusters.d/” configutarion

i added the following lines:  
`remote: “ssh”`  
`submit_host: “my_cluster”`  
`ssh_hosts: [“my_cluster”]`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex015/uploads/osc/original/2X/b/bae70bd0ed39a3ae769c2108155f4cb3e9da8385.png) [@system](https://discourse.openondemand.org/u/system)\
**Post date:** [May 20, 2026, 9:57am UTC](https://discourse.openondemand.org/t/need-help-tried-everything-ondemand-interactive-apps-schedule-desktop-fails-auth/4365/14 "2026-05-20T09:57:19Z")

</div>

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.
