# Need help with mapping usernames

**URL:** <https://discourse.openondemand.org/t/need-help-with-mapping-usernames/3346>\
**Category:** Get Help\
**Created:** [March 12, 2024, 2:18pm UTC](https://discourse.openondemand.org/t/need-help-with-mapping-usernames/3346 "2024-03-12T14:18:53Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [March 13, 2024, 4:33pm UTC](https://discourse.openondemand.org/t/need-help-with-mapping-usernames/3346/6 "2024-03-13T16:33:01Z")

</div>

> [@rgas20](#):
>
> it seems like the university.edu was being mapped to university.local correctly in the error message (but OOD didn’t like it).

Did you see the ticket that error message related to? I did recall this correctly - you have this discourse topic for a similar error. I suspect that’s what’s causing these `Address already in use` errors - somehow the user can boot the PUN, but can’t actually access the socket as that user. And I suspect the reason is that they have different domains. I mean the user that started the PUN has one domain and somehow the user that’s trying to access the socket has a different domain and somehow SSSD/Linux is seeing those as distinct users.

Which is to say - OOD doesn’t like the different domains because I believe the different domains cause the `Address already in use` issue. So hopefully it fixes that for you as well! 🤞

> [@Issues with nginx error (98: Address already in use)](https://discourse.openondemand.org/t/issues-with-nginx-error-98-address-already-in-use/1627):
>
> All, I’ve seen some similar discussion on the topic but so far we haven’t been able to resolve this in our environment. A handful of our OnDemand users get this error every single time they log in: Error – /opt/ood/nginx\_stage/lib/nginx\_stage/views/pun\_config\_view.rb:110: warning: Using the last argument as keyword parameters is deprecated; maybe \*\* should be added to the call /opt/ood/nginx\_stage/lib/nginx\_stage/configuration.rb:244: warning: The called method `app\_config\_path’ is defined he…

> <https://github.com/OSC/ondemand/issues/1759>
>
> Dear All,
> Kindly help me resolve this issue below.
> I deployed a new open OnDeman…d system on our small redhat HPC cluster. the ood is running on centOS 7.9 configured with OnDemand-dex with freeipa IdM which integrate with Microsoft AD such that some users account are directly create on freeipa and others from the Microsoft AD. All users can ssh through ood node terminal to the cluster. 
> However, only the user login created in freeipa can login through ood web UI. 
> secondly, these successful logins also gives the error message below.
> 
> Error -- nginx: \[emerg\] bind() to unix:/var/run/ondemand-nginx/mftest@mendy.mrc.gm/passenger.sock failed (98: Address already in use)
> nginx: \[emerg\] bind() to unix:/var/run/ondemand-nginx/mftest@mendy.mrc.gm/passenger.sock failed (98: Address already in use)
> nginx: \[emerg\] bind() to unix:/var/run/ondemand-nginx/mftest@mendy.mrc.gm/passenger.sock failed (98: Address already in use)
> nginx: \[emerg\] bind() to unix:/var/run/ondemand-nginx/mftest@mendy.mrc.gm/passenger.sock failed (98: Address already in use)
> nginx: \[emerg\] bind() to unix:/var/run/ondemand-nginx/mftest@mendy.mrc.gm/passenger.sock failed (98: Address already in use)
> nginx: \[emerg\] still could not bind()
> 
> 
> 
> ┆Issue is synchronized with this \[Asana task\](https://app.asana.com/0/1201735133575781/1201737341353196) by \[Unito\](https://www.unito.io)

---

_[View the full topic](https://discourse.openondemand.org/t/need-help-with-mapping-usernames/3346)._
