No implicit conversion of Hash into Array when trying to submit RStudio or Matlab session

Dear all,

I successfully added both apps:

However, when trying to launch a session for any of the two I get:

Failed to submit session with the following error:
no implicit conversion of Hash into Array





Could you help me with resolving this issue, thanks in advance!


Are you using Torque or Slurm? If you are using any other adapter but Torque you should convert the value of the “native” key in the submit.yml.erb to an array.

All of the adapters support specifying an array of “native” command line arguments you would pass to the submit command (whether that be sbatch or qsub or bsub etc.). You would replace spaces with commas and put quotes around each argument (i.e. native: [ "-d", "after:1234.myjob"])

Only the Torque adapter also supports a hash - this difference goes back to a time when we only had Torque (since thats what we currently use at OSC) and had an adapter using the C library.

I might need to call this out in the documentation. If what I’m suggesting is the problem, would adding a warning to be helpful. Or better yet, just update OSC’s apps to use the array-style arguments so that they work.

Long term we need to add a sensible abstraction to specifying resources like nodes and cores when we submit a job - then we could drop using “native” in these apps and the OSC specific ones would become more generic.

im using slurm.
and my submit.yml.erb is exactly as it’s displayed on the link, including lines 11-13.
still the same error message…

Have you solved your problem or are you still having difficulties here?

The matlab app is Torque specific. The bc_num_slots is a special attribute that for Slurm adds -N 1 (or whatever number of nodes specified) so you should just delete the entire script section from submit.yml.erb

Of course you would also delete the ppn and num_cores etc from the form.yml since they wouldn’t be used. Unless you were wanting to offer control over those when submitting the job.

I found that I had to use different formatting altogether to get things working for me. I was also getting the above error while troubleshooting. This thread has my solution that may be helpful for someone in the future: