# Running Jupyter on K8s via OOD

**URL:** <https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173>\
**Category:** Get Help\
**Tags:** question\
**Created:** [April 8, 2025, 4:17pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173 "2025-04-08T16:17:13Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![KanBe](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/kanbe/32/2635_2.png) [@KanBe](https://discourse.openondemand.org/u/KanBe)\
**Post date:** [April 8, 2025, 4:17pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173/1 "2025-04-08T16:17:13Z")

</div>

We have a Kubernetes cluster set up on System A. Using the Kubernetes API, we are able to reach it on System B where Open On Demand lives. Currently, I’ve set up a Jupyter app to work with Kubernetes; however, I’m seeing an `error: error reading input for Password` message in the web app. I’ve not been able to track down where/why this is happening yet. I was wondering if anyone recognizes this problem and how they fixed it.

Additional information:

- We have an auth type of `managed` for the Kubernetes cluster configuration file (`k8s.yml`)
- We have bootstrapped the k8s cluster but not the OOD web node [based on the docs](https://osc.github.io/ood-documentation/latest/installation/resource-manager/kubernetes.html)

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [April 8, 2025, 4:56pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173/2 "2025-04-08T16:56:57Z")

</div>

Is this Jupyter that’s returning the error or OnDemand?

---

<div class="post-metadata">

**Author:** ![KanBe](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/kanbe/32/2635_2.png) [@KanBe](https://discourse.openondemand.org/u/KanBe)\
**Post date:** [April 8, 2025, 5:03pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173/3 "2025-04-08T17:03:23Z")

</div>

The error is a red box titled “Failed to submit session with the following error:” on the jupyter app’s page on Open On Demand. A juptyer instance is never created or launched from what I can tell.

---

<div class="post-metadata">

**Author:** ![jeff.ohrstrom](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/jeff.ohrstrom/32/136_2.png) [@jeff.ohrstrom](https://discourse.openondemand.org/u/jeff.ohrstrom)\
**Post date:** [April 8, 2025, 5:08pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173/4 "2025-04-08T17:08:01Z")

</div>

OK then somehow your `~/.kube/config` isn’t correct and/or OnDemand isn’t using it correctly. That’s `kubectl` asking for your password which means it’s not using the right `--context`. You c

- spot check your `~/.kube/config` to ensure that it has your OIDC information with the right context & cluster information.
- spot check your `/var/log/ondemand-nginx/$USER/error.log` for the exact `kubectl` command you’re issuing. It should be using the right context (I’m just recalling this from memory, but I believe all we issue is `--context`, but there could be more flags we’re passing).

---

<div class="post-metadata">

**Author:** ![KanBe](https://sea1.discourse-cdn.com/flex015/user_avatar/discourse.openondemand.org/kanbe/32/2635_2.png) [@KanBe](https://discourse.openondemand.org/u/KanBe)\
**Post date:** [April 8, 2025, 5:26pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173/5 "2025-04-08T17:26:16Z")

</div>

Hmm, I think the latter may have clued me in. It seems like there’s an expectation for Kubernetes to be installed on the OOD webnode and its executable to be at `/bin/kubectl`. If that’s true, I’ll start poking there. Since we’re using `microk8s` we can set up a link to the proper executable at that path (`/bin/kubectl`). Otherwise, I think the kube config file and `--context` look right.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex015/uploads/osc/original/2X/b/bae70bd0ed39a3ae769c2108155f4cb3e9da8385.png) [@system](https://discourse.openondemand.org/u/system)\
**Post date:** [October 5, 2025, 5:27pm UTC](https://discourse.openondemand.org/t/running-jupyter-on-k8s-via-ood/4173/6 "2025-10-05T17:27:09Z")

</div>

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.
