Add user manually to OOD server

Hi all,

I have installed OOD in ubuntu20.04 and trying to configure slurm and submit a job using the OOD web portal.
I have followed the ODD installation in this page and the default email, username and password are
email: ood@localhost
username: ood
password: password

Now, I want to add a new user manually to login ODD e.g. user1 since this is the user configured in other nodes in slurm system.
Is there any documentations I can follow? I am not looking into using LDAP or other authentication methods yet.

Hi Yusuke.

Thanks for the post.

This link will give you all Open OnDemand 2.0 authentication methods.

https://osc.github.io/ood-documentation/latest/authentication.html

Hope this helps.

Thanks,
-gerald

Default authentication method was ‘Basic’ in previous version of OOD.(Now the default is open-id connect with Dex IdP.) Basic authentication is not recommended due to security issues; but if you really don’t need any other authentication method, basic linux auth would be the simplest & easiest option.
This page shows how to configure auth option in ood_portal.yml file. Using basic option, all you need to do is to add username and password to the .htpasswd file.

htpasswd -c /etc/apache2/.htpasswd username password

Hi Yoohee,
Thanks for the response.

As you suggested, I have modified the ood_portal.yml into

auth:
  - "AuthType Basic"
  - "AuthName \"private\""
  - "AuthUserFile \"/etc/apache2/.htpasswd\""
  - "RequestHeader unset Authorization"
  - "Require valid-user"

and ran

sudo /opt/ood/ood-portal-generator/sbin/update_ood_portal 
sudo systemctl restart apache2
sudo systemctl restart ondemand

However, the login page no longer shows up and I received “This site can’t be reached” error.
Did I have to remove ondemand-dex? And what else I can do to precede?

Thanks,
Yusuke

Hi Yusuke,
If you see the error message “This site can’t be reached”, I guess there must be some misconfigurations in /etc/apache2/sites-available/ood-portal.yml file. Check if there are some OIDC options defined in the file. They are expected not to exist if you use basic auth.

Dex support will auto-enable if ondemand-dex package is installed. So ood_portal_generator will try to add configurations that are relevant to dex even if you didn’t define anything about dex in your /etc/ood/ood_portal.yml file. If you use basic authentication, you have no need of dex IdP and ondemand-dex service. So you’d better remove dex-related files and inactivate ondemand-dex service.

However, the login page no longer shows up and I received “This site can’t be reached” error.
Did I have to remove ondemand-dex? And what else I can do to precede?

Hi Yusuke,

If you are going to use Basic Auth, you will need to remove ondemand-dex

Thanks,
-gerald

Hi Yoohee and Gerald,

Thank you for the advice. I will continue to work on it and update this thread.

Yusuke

Hi Yusuke.

Thanks for follow-up. If you run into other issues or have additional questions, please feel free to ask here.

Thanks,
-gerald