Built in Support Ticket problem: Error: error=Net::ReadTimeout"

Hi,
I’ve enabled the “Submit Support Ticket” form in my v3.1.1 installation. I want to send a ticket from this form to our Kace installation. I’ve used the command line to send and email to Kace and that worked fine. Note kace will only accept emails from username@mydomain.com.
But I keep getting an error when I try to submit a ticket:
error=Net::ReadTimeout"
the full error is:
App 1780678 output: [2024-03-28 12:16:29 -0400 ] ERROR “Could not create support ticket. support_service=#SupportTicketEmailService:0x00007f9fe0e83488 error=Net::ReadTimeout”

The support_ticket.yml file in /etc/ood/config/ondemand.d is:
support_ticket:

email section is required and should always be present.

It configures how the support ticket email is sent

email:
to: “something@helpdesk”
from: “dweise@upenn.edu”

description: |
Please let us know how we can help at PMACSv11, but please be as descriptive as possible in the email.
delivery_settings:
address: ‘mailserver2.domain’
port: 25
domain: ‘mailserver2.domain’
authentication: ‘plain’
open_timeout: 500
read_timeout: 500
attributes:
email:
required: true
subject:
value: "OnDemand Problem: "
form:
- email
- subject
- attachments
- description
So why isn’t it working, if the system works?
thanks,
–David

I would ask where you submitted this email from. Was in on the same machine that OOD runs? Network timeouts generally mean there’s a connectivity/firewall issue.

It would seem that the node that you’ve installed OOD on cannot connect to mailserver2.domain:25. Can you telnet or similar to it from the machine that OOD is installed on?

Hi,
I can use the linux command line to send an email, and that works fine. No matter how I configure the form, it just times out. Last try, I even stripped out the mail servers, hoping that Ondemand would use the system to send the email.
–David

You can change the delivery_method to sendmail I think if that’s something you want to try. But I would ask again, if you’re on the OOD machine as a regular user, can you connect to mailserver2.domain:25 (using telnet or similar) from that same machine that OOD is installed on?

https://osc.github.io/ood-documentation/latest/customizations.html#configuration

Hi,
Yes as me, I can telnet to the mailserver at port 25. I’ll just changed the deliery_method to “smtp” still the same error.
App 3179075 output: [2024-04-02 14:47:48 -0400 ] ERROR “Could not create support ticket. support_service=#SupportTicketEmailService:0x00007f9889248e38 error=Net::ReadTimeout”

We don’t do interactive sessions yet with apps. Could that be a problem?
–David

On the same machine that OOD is installed on? That’s the important bit. You have to replicate on the same machine because the machine that OOD is installed on cannot connect to that destination.

SMTP is the default setting which means you were already using smtp. If you want to try with sendmail you’ll have to configure it to use sendmail.

No, the error is a network read timeout. So if OOD can connect, it’s timing out trying to read the response which suggests that maybe the mail relay mailserver2.domain actually isn’t sending a response. Are there any logs on it’s side that would indicate why it’s not sending a response?

Hi,
Mailserver2 isn’t even getting a connect from OOD.
–David

Can you share your configs again? You can properly format yaml content by using 3 backticks like so:

```yaml
format: some stuff
```

I wonder if there’s some issue with your configs where it’s not even picking up mailserver2.

Hi,
Found the issue. Our in house postfix needed to be fixed. Per Redhat
vi /etc/postfix/main.cf
and add line:
compatibility_level = 2

Article here: What is "compatibility_level" option in postfix? How to use it? - Red Hat Customer Portal
Found the error in /var/log/maillog

1 Like