Can't navigate to autofs directories through the ondemand interface

We have all our different labs directories setup as automounts. This usually works fine if you cd directly to the directory. It doesn’t seem to work through the ondemand web file explorer. Is there any way to get this to work with automounts or do I need to switch to fstab mounts?

I’m probably going to swap everything to fstab mounts soon, autofs was just how it has been done in the past. You can only change so many things at a time.

The automounts seem to work on our CentOS7 running ondemand 1.6.25.
The one that is not working is the new Rocky8 running ondemand 3.1.4

Yea we use autofs as well, though it’s on RHEL 8 (and RHEL 7 in the past). I just checked our systems and we’re running version 5.1.4-109.el8_9.1.

Checking our configs all we have set is USE_MISC_DEVICE="yes", though I don’t know if that’s what RHEL gave us or if we configured it (I suspect we didn’t configure it because it’s not a puppet file, but can’t say for sure).

I suspect because it doesn’t work on Rocky that there’s some setting you’d need. @tdockendorf do you have any insight here?

There should be errors or some more information in /var/log/messages if you have syslog setup using pretty standard log forwarding. Might have to enable verbose logging to get useful information:

$ cat /etc/autofs.conf

[ autofs ]
logging = verbose

What do your /etc/auto.master and corresponding mapping files look like? We’ve successfully used autofs with OnDemand on both RHEL7 and RHEL8. OSC doesn’t touch /etc/sysconfig/autofs so likely you have the same as we do since I’d hope Rocky isn’t changing too much of what comes from upstream RHEL RPMs.

There are a lot of things that can cause autofs to not work, and most of them have nothing to do with autofs. If manual mounts work but autofs mounts do not work then would need to see how autofs is configured and any errors but I doubt any of these issues are specific to OnDemand unless Rocky has introduced bugs into their repackaged autofs RPMs.

I had USE_MISC_DEVICE=“yes” in my config. I added BROWSE_MODE=“yes” and it’s working now. Also I’ll probably get a lot fewer tickets for missing directory since people tend to cd incrementally instead of directly.

1 Like