Failed to init libxfconf Could not connect No such file or directory on OOD 1.8.20 and Red Hat 8

I am migrating from CentOS 7.9 to Red Hat 8.3 and everything in the OOD apps works with the exception of remote desktop apps.
Desktop Xfce installed from EPEL

The VNC session comes up but has an error “Unable to contact setting server”

The output.log has the following error:

WebSocket server settings:
  - Listen on :65522
  - Flash security policy server
  - No SSL/TLS support (no cert file)
  - Backgrounding (daemon)
Scanning VNC log file for user authentications...
Generating connection YAML file...
Launching desktop 'xfce'...
Failed to init libxfconf: Could not connect: No such file or directory.
Failed to init libxfconf: Could not connect: No such file or directory.
Gtk-Message: 09:14:01.392: GtkDialog mapped without a transient parent. This is discouraged.
Setting VNC password...
Generating connection YAML file...

The Xfce interactive desktop works when logging in directly on the console on the server, so I don’t have any suspicion that Xfce might not be working.
I’ve found mentioned of this type of error on the web but the info is dated and did not seem related. Has anyone encountered this or know what I might overlooked?

Thank you for you help.

At the risk of asking the obvious, do you have the xconf (and maybe xconf-devel) packages installed on the compute nodes?


lol, sometimes it is important to ask the obvious
I do have xfconf-4.14.3-1.el8.x86_64 but did not have xconf-devel, I installed it but the results are the same.

I also confirmed the library is in place on all the compute nodes.


I think I found the issue. I need to add unset DBUS_SESSION_BUS_ADDRESS to the on the remote desktop app.

Things are working as expected now.