Interactive Desktop - undefined method error - SOLVED


We have one cluster using PBSpro working with Interactive Desktops, but when I try to setup another system using PBSpro I get an undefined method error and the logs do not give much to go on.

Here is the error I receive when I try to submit a new desktop session:
undefined method `desktop’ for #<BatchConnect::SessionContext:0x000000000438a820>

The main difference between the two clusters is that the one that works is a head node with attached compute nodes and the other is the head node and compute node on the same system. Also, to try and rule out the scheduler we tested submitting jobs through the Job Composer and they work fine.

I’m not sure what data you would like to see to troubleshoot this issue, so please let me know and I will add it to this thread.



@msgambati-INL would you mind sharing your form.yml and submit.yml.erb? I am able to cause a similar error if I have a variable that isn’t properly specified in form.yml that is then called in submit.yml.erb.

Here you go.


# /etc/ood/config/apps/bc_desktop/oodview.yml
title: "OODView 2D/3D Desktop"
cluster: "oodview"
  desktop: "mate"
submit: "submit/oodview_submit.yml.erb"
  - bc_account


# /etc/ood/config/apps/bc_desktop/submit/oodview_submit.yml.erb
    - "-l"
    - "select=1:ncpus=1:mem=2gb"


We can mark this issues as solved or just delete this post :slight_smile:. After reading the documentation more closely I realized I cannot declare the form the way I did. I was using that to not have items appear on the form, but what I should have done is set them to null in the attributes section. Sorry for wasting your time on this.



Not a problem at all Matt, all questions are welcome!