noVNC not connecting to server websockify

I am working on a new instance of ood connecting to a slurm cluster. I am attempting to get interactive desktops connecting to xfce. I am able to get the job started but the noVNC session fails.

The output.log

Setting VNC password...
Starting VNC server...

WARNING: aoraki03:2 is taken because of /tmp/.X2-lock
Remove this file if there is no X server aoraki03:2

WARNING: aoraki03:1 is taken because of /tmp/.X1-lock
Remove this file if there is no X server aoraki03:1
Killing Xvnc process ID 19311
Xvnc process ID 19311 already killed
Xvnc did not appear to shut down cleanly. Removing /tmp/.X11-unix/X2
Xvnc did not appear to shut down cleanly. Removing /tmp/.X2-lock
Killing Xvnc process ID 19671
Xvnc process ID 19671 already killed
Xvnc did not appear to shut down cleanly. Removing /tmp/.X11-unix/X1
Xvnc did not appear to shut down cleanly. Removing /tmp/.X1-lock

Desktop 'TurboVNC: aoraki03:1 (higje06p)' started on display aoraki03:1

Log file is vnc.log
Successfully started VNC server on aoraki02.uod.otago.ac.nz:5901...
Script starting...
Starting websocket server...
The system default contains no modules
  (env var: LMOD_SYSTEM_DEFAULT_MODULES is empty)
  No changes in loaded modules

Launching desktop 'xfce'...
WebSocket server settings:
  - Listen on :24033
  - No SSL/TLS support (no cert file)
  - Backgrounding (daemon)
Scanning VNC log file for user authentications...
Generating connection YAML file...

(xfwm4:20492): xfwm4-WARNING **: 14:34:51.429: Unsupported GL renderer (llvmpipe (LLVM 13.0.1, 256 bits)).

** (xfce4-screensaver:20528): WARNING **: 14:34:52.470: screensaver already running in this session

** (wrapper-2.0:20513): WARNING **: 14:34:52.720: No outputs have backlight property

** (wrapper-2.0:20512): WARNING **: 14:34:52.791: Binding 'XF86AudioMicMute' failed!

(wrapper-2.0:20512): pulseaudio-plugin-WARNING **: 14:34:52.791: Could not have grabbed volume control keys. Is another volume control application (xfce4-volumed) running?

(wrapper-2.0:20512): libnotify-WARNING **: 14:34:52.796: Failed to connect to proxy

(wrapper-2.0:20512): Gtk-WARNING **: 14:34:52.863: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(wrapper-2.0:20513): Gtk-WARNING **: 14:34:52.919: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)

(wrapper-2.0:20532): Gtk-WARNING **: 14:34:52.943: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner XfceArrowButton)

VNC.log

TurboVNC Server (Xvnc) 64-bit v2.2.7 (build 20211221)
Copyright (C) 1999-2021 The VirtualGL Project and many others (see README.txt)
Visit http://www.TurboVNC.org for more information on TurboVNC

04/08/2022 14:34:49 Using security configuration file /etc/turbovncserver-security.conf
04/08/2022 14:34:49 Enabled security type 'tlsvnc'
04/08/2022 14:34:49 Enabled security type 'tlsotp'
04/08/2022 14:34:49 Enabled security type 'tlsplain'
04/08/2022 14:34:49 Enabled security type 'x509vnc'
04/08/2022 14:34:49 Enabled security type 'x509otp'
04/08/2022 14:34:49 Enabled security type 'x509plain'
04/08/2022 14:34:49 Enabled security type 'vnc'
04/08/2022 14:34:49 Enabled security type 'otp'
04/08/2022 14:34:49 Enabled security type 'unixlogin'
04/08/2022 14:34:49 Enabled security type 'plain'
04/08/2022 14:34:49 Desktop name 'TurboVNC: aoraki03:1 (higje06p)' (aoraki03:1)
04/08/2022 14:34:49 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
04/08/2022 14:34:49 Listening for VNC connections on TCP port 5901
04/08/2022 14:34:49   Interface 0.0.0.0
04/08/2022 14:34:49 Framebuffer: BGRX 8/8/8/8
04/08/2022 14:34:49 New desktop size: 1240 x 900
04/08/2022 14:34:49 New screen layout:
04/08/2022 14:34:49   0x00000040 (output 0x00000040): 1240x900+0+0
04/08/2022 14:34:49 Maximum clipboard transfer size: 1048576 bytes
04/08/2022 14:34:49 VNC extension running!

I can see there are websockify issues but I can confirm websockify is in the path of the user on the server.

image

path to websockify is set in the clusters.d file

 batch_connect:
     basic:
       script_wrapper: |
         module purge
         %s
     vnc:
       script_wrapper: |
         module purge
         export PATH="/opt/TurboVNC/bin:$PATH"
         export WEBSOCKIFY_CMD="/usr/local/bin/websockify"
         %s
       set_host: "host=$(hostname -A | awk '{print $1}')"

I have the submit.yml.erb pointing to one host and that host has the firewall off (for testing)

# /etc/ood/config/apps/bc_desktop/submit/my_submit.yml.erb
---
script:
  native:
    - "-N"
    - "<%= bc_num_slots.blank? ? 1 : bc_num_slots.to_i %>"
    - "--nodelist=aoraki[03]"

Any help appreciated.

OK… I can see that the connection.yml is putting the wrong server name in. when I edit that file and connect it works. How is the connection.yml built?

Add apache SSL Certificate.

I was able to resolve this by correcting the the host config in the clusters.d/cluster.yml file.