OnDemand Installation - Rubygem bundler missing

Trying to install Ondemand v 2.0.23 on RHEL 8.6.
I’m getting these error messages:

Error:
Problem: package ondemand-2.0.20-1.el8.x86_64 requires ondemand-passenger = 6.0.7, but none of the providers can be installed

  • package ondemand-passenger-6.0.7-1.el8.x86_64 requires libruby.so.2.7()(64bit), but none of the providers can be installed
  • conflicting requests
  • package ruby-libs-2.7.1-133.module+el8.3.0+7192+4e3a532a.x86_64 is filtered out by modular filtering
  • package ruby-libs-2.7.3-136.module+el8.4.0+10728+4c884998.x86_64 is filtered out by modular filtering
  • package ruby-libs-2.7.4-137.module+el8.4.0+12025+f744ca41.x86_64 is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

When trying to install ondemand-ruby, I get this:

Error:
Problem: package ondemand-ruby-2.0-2.el8.x86_64 requires rubygem-bundler >= 2.1, but none of the providers can be installed

  • cannot install the best candidate for the job
  • package rubygem-bundler-2.1.4-133.module+el8.3.0+7192+4e3a532a.noarch is filtered out by modular filtering
  • package rubygem-bundler-2.1.4-136.module+el8.4.0+10728+4c884998.noarch is filtered out by modular filtering
  • package rubygem-bundler-2.2.24-137.module+el8.4.0+12025+f744ca41.noarch is filtered out by modular filtering
  • package rubygem-bundler-2.2.22-140.module+el8.5.0+12856+0c654ebc.noarch is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

Hi Equiros.

Thanks for the info. We’ll research and see what’s up.

Thanks,
-gerald

1 Like

I get similar errors when trying to install on RHEL 7.9 as well. I suppose I’m missing a repo. I just don’t know which.

1 Like

Hi @tdockendorf,

You have any thoughts on why this may be failing?

Thanks,
-gerald

For RHEL 8.6 it appears you don’t have the ruby:2.7 DNF module enabled. Try this as root:

dnf module reset ruby
dnf module enable ruby:2.7

The module reset/enable is covered here: v2.0 Release Notes — Open OnDemand 2.0.20 documentation and the repos needed are here: 1. Install Software From RPM — Open OnDemand 2.0.20 documentation

For RedHat 7.9 you need SCL repos enabled:

subscription-manager repos --enable=rhel-server-rhscl-7-rpms

You will need EPEL on both RHEL 8 and RHEL 7 too.

Thanks for that info. Had not considered SCLs on RHEL 7.

As for the issue on RHEL 8, yes, enabling the ruby 2.7 module got me farther.
It’s also complaining about nodejs, which I imagine is the same process.

After enabling ruby2.7 and nodejs12, everything installed great.

Thanks for the help! Highly appreciated!

1 Like