OOD dependencies on CentOS 6.9


I have tried to follow the installation instructions again; installing SCL manually (because these are not available on CentOS 6.9 anymore?) as follows:

yum install http://mirror.centos.org/centos/6/extras/x86_64/Packages/centos-release-scl-rh-2-3.el6.centos.noarch.rpm

Then, yum install rh-ruby24 , httpd24, rh-nodejs6 (works) but for "yum install rh-git29 " there is the following dependency problem:

—> Package httpd24-libcurl.x86_64 0:7.61.1-1.el6 will be installed
–> Processing Dependency: libnss3.so(NSS_3.34)(64bit) for package: httpd24-libcurl-7.61.1-1.el6.x86_64
–> Finished Dependency Resolution
Error: Package: httpd24-libcurl-7.61.1-1.el6.x86_64 (centos-sclo-rh)
Requires: libnss3.so(NSS_3.34)(64bit)

CentOS 6.9 has NSS of an earlier version, nss-3.28.4 .
Is there a workaround for this dependency problem?
Thank you very much in advance!

Grigory Shamov
University of Manitoba

I’m curious why you specified a URL in that install; centos-release-scl-rh is part of the normal repositories, and thus available via

yum install centos-release-scl-rh

You might try

rpm -q nss

and see if maybe you only have the i686 version installed. I think the version you have should be good enough, if you have the x86_64 variant. You should be able to locate nss-3.28.4 at http://vault.centos.org/6.9/updates/x86_64/Packages/

That said, it’s probably best to update to the current release of CentOS before trying to deploy a possibly public facing web service.


Thanks for the reply!

The problem is that it needs NSS_3.34 ? I definitely do have 3.28 installed but still get the error.

Grigory Shamov

Dig around in


and you can probably find a set of rpms that care compatible with each other, and your 6.9 system.



Thanks! Yes,

yum install http://vault.centos.org/6.9/sclo/x86_64/rh/httpd24/httpd24-curl-7.47.1-1.1.el6.x86_64.rpm

did satisfy the dependency. 7.61 has a newer NSS than 7.47!

Grigory Shamov

Now it fails to start nginx sudo: no tty present; the security logs show that for “apache : user NOT in sudoers”.

Is that a missing documentation step for CentOS6, adding apache to sudoers in order to start nginx instances?


It aounds like your sudoers is configured with “requiretty” turned on. If that is correct, you’ll need to add a


to the /etc/suoders.d/ood line.