OOD upgrade from 1.5 to 1.6

Just upgraded to 1.6 OOD from 1.5 using yum on CentOS7 system. Is this the expected new look on the page? Verify if the upgrade did work correctly as there were several warning messages on the clean up portion. Looks to have been trying to remove files that didn’t exist.

@cj.keist that is not the expected look. It looks like the CSS file wasn’t loaded properly. What happens if you clear your browser’s cache and reload the page?

Thanks for the reply, I have tried clearing the cache and running it from Safari, Chrome and Firefox. All same look. Should I try a force yum reinstall? These were the steps I followed for the upgrade:

sudo yum install -y https://yum.osc.edu/ondemand/1.6/ondemand-release-web-1.6-1.el7.noarch.rpm
yum clean all
yum update ondemand

@cj.keist those look like the correct upgrade steps to me. Using Vagrant I installed 1.5.x and ran through those steps to a get a working 1.6 system.

Before forcing a reinstall I would check the output of sudo rpm -Va ondemand* and look for missing CSS files.

We do have a known issue where files from the pre-RPM days can cause problems during upgrades. I would also check for the existence of /var/www/ood/apps/sys/dashboard/public/assets/.sprockets-manifest-5ca2872ba7a810121bb8c96da3aa744d.json. If there are other Sprocket manifest files in that directory they should be removed.

Thanks for the reply. I tried removing the .sprockets-manifest* files but didn’t fix the issue. Here is the rpm command output:

rpm -Va ondemand*
S.5…T. c /etc/ood/config/ood_portal.yml

This is a VM so I reverted back to OOD1.5 and redid the upgrade and still came to the same issue with the dashboard not looking correct. During the cleanup phase, it gave a ton of warnings on removing files that didn’t exist.

I’m unable to replicate and I tried pretty hard to corrupt that CSS file (by giving garbage to the dashboard’s env file). Can you share your dashboards’ env file?

I’m also curious to see how/if your css files are being generated.

Can you show me an image similar to this? I took this from the developer tools in firefox, you can do the same in any browser you like. Specifically I’m interested in

Also if you don’t mind can you give us a listing of what’s in this directory?

Hello, where is the env file located? Is this the path /etc/ood/config/apps/dashboard/env? If so I don’t have that file on our system it looks like. Checking my OOD 1.5 snapshot the folder and file didn’t exist there too. Here is screen shot of the dashboard page in developer view. Let me know if this is what you are looking for.

ls of assets here:










@cj.keist yes that is what I’m looking for and as you can see you’re trying to access the wrong .js file. Apparently it is due to the sprockes file and I was able to replicate when I removed it.

You need .sprockets-manifest-5ca2872ba7a810121bb8c96da3aa744d.json and no other. I think in your comment above, you removed .sprockets*. This is problematic because that file is configuring the dasbhoard app.

In the correct case it has this json element:

Whereas you’re older version of the file seems to be pointing to
which no longer exists.

So you do indeed have a bad .sprockets file pointing to non-existant css/js files. Please ls -la on that same assets directory and ensure you have only one .sprockets file and it is the hash starting with 5ca28.

Thank you. I reinstalled the 1.6 version from VM snapshot. Here is how the asset directly looks like after the upgrade:
[root@ondemand assets]# ls -al
total 604
drwxr-xr-x 4 root root 4096 Jul 15 11:18 .
drwxr-xr-x 4 root root 4096 Jul 15 11:17 …
-rw-r–r-- 1 root root 199278 Jun 28 08:57 application-05ef8da03b5b8811283da1170e2a07bc5865b21764af5054129db60afff5f593.css
-rw-r–r-- 1 root root 36136 Jun 28 08:57 application-05ef8da03b5b8811283da1170e2a07bc5865b21764af5054129db60afff5f593.css.gz
-rw-r–r-- 1 root root 238812 Jun 28 08:57 application-8c6ae4489de9fd653dec146e15d91ba978a88fc8f0b98a9f15bceaa7a8377104.js
-rw-r–r-- 1 root root 77344 Jun 28 08:57 application-8c6ae4489de9fd653dec146e15d91ba978a88fc8f0b98a9f15bceaa7a8377104.js.gz
drwxr-xr-x 2 root root 4096 Jul 15 11:17 bootstrap
drwxr-xr-x 2 root root 4096 Jul 15 11:17 font-awesome
-rw-r–r-- 1 root root 5610 Jun 18 12:31 OpenOnDemand_powered_by_RGB-cb3aad5ff5350c7994f250fb334ddcc72e343233ce99eb71fda93beddd76a847.svg
-rw-r–r-- 1 root root 2204 Jun 18 12:31 OpenOnDemand_powered_by_RGB-cb3aad5ff5350c7994f250fb334ddcc72e343233ce99eb71fda93beddd76a847.svg.gz
-rw-r–r-- 1 root root 3386 Jun 18 12:31 OpenOnDemand_stack_RGB-e9b21db6a659867fbf0ac60241622ebed7f74029c0498f09c72689c024011874.svg
-rw-r–r-- 1 root root 1457 Jun 18 12:31 OpenOnDemand_stack_RGB-e9b21db6a659867fbf0ac60241622ebed7f74029c0498f09c72689c024011874.svg.gz
-rw-r–r-- 1 root root 11460 Jun 28 08:58 .sprockets-manifest-5ca2872ba7a810121bb8c96da3aa744d.json
-rw-r–r-- 1 root root 11460 Jan 23 09:39 .sprockets-manifest-69b47d37b25336d6ffa7370036fd33a3.json

I then removed the .sprockets-manifest-69b47d37b25336d6ffa7370036fd33a3.json file.
It is working now. I’m sure I did this before, but who knows. Thanks for the help.

For reference to anyone reading this topic in the future, the corresponding GitHub issue is https://github.com/OSC/ondemand-packaging/issues/42