Package dependencies for v 1.7 and 1.8

Since the 1.8 rpms were added to the ondemand repo, simply trying to update the ondemand package to the latest available version no longer works. It tries to update dependencies ondemand-apache, ondemand-runtime, ondemand-nodejs, ondemand-ruby, ondemand-python to 1.8 which is incompatible with the package ondemand-1.7.10-2.el7 (requires dependencies to be 1.7, not 1.8). As a work-around, changing the baseurl for the repo to have ‘1.7’ instead of ‘latest’ for the version results in compatible dependencies being selected.

(System: RHEL 7.7, yum 3.4.3)

@tdockendorf can you advise?

@milberg I would not advise using the latest repo unless absolutely necessary. When OSC begins testing 1.8 the repos for latest will have 1.8 packages and there will probably be a time period where the dependencies for 1.8 exist before actual 1.8 releases of OnDemand which is necessary to actually build ondemand RPMs. The latest repo has since had the 1.8 build dependencies removed so we could continue building 1.7 RPMs but once we begin preparing to build 1.8 those RPMs will be put back into the latest repo.

@tdockendorf Thanks for the info!