RStudio server on arm64 node

Hi all,

I am trying to install RStudio 2023.09.1-494, Singularity 4.02, Rocky Linux 8.4, on arm64 server. Had to compile the RStudio server from source. Now I can let it run as a service or interactively on the terminal. But could not let it work through Singularity. Also added " --server-user " to the singularity option, still no working.

The error message is as bellow:

2023-11-23T16:01:04.633476Z [rserver] ERROR Could not find details for server user ‘feng’; LOGGED FROM: virtual rstudio::core::ProgramStatus rstudio::server::Options::read(int, char* const*, std::ostream&) src/cpp/server/ServerOptions.cpp:302
2023-11-23T16:01:04.635427Z [rserver] ERROR system error 2 (No such file or directory) [description: User not found., user-value: feng]; OCCURRED AT rstudio::core::Error rstudio::core::system::User::Impl::populateUser(GetPasswdFunc&, T) [with T = const char* GetPasswdFunc = std::function<int(const char*, passwd*, char*, long unsigned int, passwd**)>] src/cpp/shared_core/system/User.cpp:68; LOGGED FROM: virtual rstudio::core::ProgramStatus rstudio::server::Options::read(int, char* const*, std::ostream&) src/cpp/server/ServerOptions.cpp:303

Can you please help!

Thanks!

Feng

Ok, found the cause. Long in short, the "script.sh.erb’ y default export /etc, /var folder, so singularity only uses passwd file for authentication, while we are using ldap. Unexport /etc folder fixed the issue.

Now I encounter another issue: after I tried to login, it reports error and gives a page to “go back”, but after click it, it stuck there doing nothing. Aby idea in what’s happening here?

The error message look like:

2023-11-25T16:02:00.415917Z [rserver] ERROR Failed to validate sign-in with invalid CSRF form; LOGGED FROM: bool rstudio::server::auth::common::validateSignIn(const rstudio::core::http::Request&, rstudio::core::http::Response*) src/cpp/server/auth/ServerAuthCommon.cpp:135

2023-11-25T16:07:36.451493Z [rserver] ERROR Failed to validate sign-in with invalid CSRF form; LOGGED FROM: bool rstudio::server::auth::common::validateSignIn(const rstudio::core::http::Request&, rstudio::core::http::Response*) src/cpp/server/auth/ServerAuthCommon.cpp:135

Also, I could avoid this login by setting " --auth-none 1". It sounds OK foe me, since when user get to this step, s/he should have gone though the OOD webportal authnetication, and our SLURM system, so it may be fine. Or is it better to still ask password to login to use RStudio?

Besides, on the “pun/sys/dashboard/batch_connect/sessions”, after the rstudio app starts, it has a “Host: >xxxx” link, but when I click it, it fails with “Host “xxxx” not specified in allowlist or cluster configs.” I have set the OOD_SSHHOST_ALLOWLIST in the script.sh, still fails. I wonder it is good to let this work, since user at this stage have got this node?

Thanks!

Ok, after setting the OOD_SSHHOST_ALLOWLIST, the “Host: >xxxx” link thing is working fine now.

Still stuck in the “ERROR Failed to validate sign-in with invalid CSRF form;”. The error message says:

![RStudio Logo]

The requested page was not found.

Please contact your system administrator for assistance, or click here to go back.