SOLVED Cannot get support for LDAP working; can't connect

NB: ended up figuring this out, was missing a setting as pointed out below.

After following the instructions for CentOS 7, I have tried to get my OOD instance authenticating to my Active Directory with no success.

- type: ldap
id: ldap
name: LDAP
host: pegasus.broken.wrx:389
insecureSkipVerify: true
insecureNoSSL: true ← this was missing
bindDN: CN=oodman,CN=Users,DC=broken,DC=wrx
baseDN: DC=broken,DC=wrx
filter: “(objectClass=user)”
username: sAMAccountName
idAttr: sAMAccountName
emailAttr: mail
nameAttr: sAMAccountName
preferredUsernameAttr: sAMAccountName
baseDN: DC=broken,DC=wrx
filter: “(objectClass=group)”
- userAttr: DN
groupAttr: member
nameAttr: cn

I get this as an error message in my browser:

Login error: failed to connect: LDAP Result Code 200 “Network Error”: read tcp> read: connection reset by peer

I’ve confirmed with ldapsearch that using these credentials from this host gets me search results. Does anyone have any idea how to get past this? If there are logs anywhere that explain what’s happening, I don’t know where they are. Nothing shows in /var/log/httpd24.


Very cool! Yea connection resets are often stuff like SSL negotiation isn’t working. Glad to hear you got it!

1 Like