SQLite error with job composer - NFS mounted drive

Hi,

We’re having an error with the deployment of the OOD, Job Composer app, as we have an NFS mounted drive, and since the Job Composer has SQLite as a component, we are running into locking issues with it. I was wondering if you guys have seen this before and if there’s a config file where we can change the location of that particular interactive app so that we can move it specifically away from the NFS-mounted spaces. Alternatively, if there is a method to use the Job Composer app on NFS-mounted drives, that would be appreciated as well.

Let me know if you need additional information.

Ravi

Hi and thanks for posting!

The issue can be resolved in NFS by passing a flag to the mount to disable locks with local_lock=none. This is what we do at OSC to prevent this issue with the job composer over NFS.

If you need some more help just let us know!

Hi Travis,

Thanks for your reply.
We tried your suggestion and changed the entry in fstab to do a mount with the local_lock-none option but encountered the same issue after remounting. The issue happens during the initialization process for the SQLite database for the job composer app.
The only workaround that worked is when we moved the DB path to /tmp, but that would be difficult to emulate for every user, and it just pointed the database, rather than the entire app to /tmp location

Is there a configuration value that can move the entire app to a particular location? Or any other changes we can make for NFS mounts. For more information, we have a GPFS filesystem that we do an NFS mount for.

Thanks.

Ravi

@tdockendorf does GPFS need something special for the NFS local_lock=none option?

Here’s how our NetApp HOME directories are mounted.

ip:/PAS0654 on /users/myhome type nfs4 (rw,relatime,vers=4.0,rsize=65536,wsize=65536,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=ip,local_lock=none,addr=ip)

I’m not sure why you’d need to move the entire app to local storage. Seems like you’d only need to lock on the sqlitelite3 database. Can you give us the error/stack trace you’re seeing?

Every NFS implementation handles locking differently, some simply ignore it entirely and do nothing irregardless of mount options. The Ganesha NFS stack for GPFS is not the greatest, especially when compared to NetApp. In the old days you just had to put “nolock” option in /etc/fstab for the mount and locking would be turned off.