Trouble installing SSL cert

Greetings all, apologize for the very newbie question, I have very basic experience installing Apache certs and that’s about it. I am working on installing an SSL cert for ondemand and when I do it seems I can no longer visit the site and I get a 500: Internal server error. Here is what I have in my ood_portal.yml, other than my LDAP information that is not listed:

# List of SSL Apache directives
# Example:
   - 'SSLCertificateFile "/ssl/"'
   - 'SSLCertificateKeyFile "/ssl/"'
   - 'SSLCertificateChainFile "/ssl/"'

I have port 443 open but I wonder if I have missed something. In the SSL log I have “Invalid method in request” but that is all I can see for now. Do I need to put the actual port i.e. 443 in the config anywhere so it knows to use it? From the example in the docs it looks like I should just need the servername and ssl info to work, but it does not. Thank you for any ideas you can send over my way.

I’m fairly sure it should work with the configs you’ve given. You shouldn’t need to add more configs to use ports 80 & 443.

When you hit the URL do you specify https? This could be the issue, you’re using http on an https site. You can use_rewrites to get the portal to automatically upgrade http on port 80 -> https on port 443.

I just recently installed OOD for the first time ever. I also configured for SSL. I followed these instructions -

If you are getting a 500 error, my guess is that you have a configuration error. I’d try these two things:

  • run this on the command line to check the configuration file: scl enable httpd24 ‘apachectl configtest’
  • view the error log to see what is causing the 500 errors - /opt/rh/httpd24/root/etc/httpd/logs/error_log


Hey sorry for the delay. Did anything new show up? I’m guessing you’re trying to hit an https site with just http. Without the redirects enabled, you’ll have to specify


Was there any update or resolution for this?