Virtual Desktop Fails to Launch

Following an upgrade from CentOS 8 to Rocky Linux 8.6, OOD (an old version 1.7.x) fails to launch virtual desktop sessions. Looking at the session error logs, the relevant portion seems to be:

Starting VNC server…
Could not start Xvnc.

Unrecognized option: -nohttpd

I can’t locate where this option is being passed. Can anyone point me in the right direction? I also don’t know what the repercussions are of simply removing it, when I do find it, or perhaps whether a new option needs to be passed instead.

Warmest regards,
Jason

Disregard. I was able to address this by following advice is TurboVNC seems to no longer have the -nohttpd option

Specifically, I removed -nohttpd from /opt/ood/ondemand/root/usr/share/gems/2.7/ondemand/2.0.20/gems/ood_core-0.18.1/lib/ood_core/batch_connect/templates/vnc.rb

1 Like