Active Job App not displaying jobs


so after getting everything set up (except SSL-Certification because that is the thing I wanna do at last) I do run into the problem of Active Jobs not displaying anything.

I haven’t submitted via the OOD server yet (as I currently have not set up SSL yet) but we have enough jobs running on our cluster that should be shown when using qstat.

Here my cluster config

       title: "cluster"
     host: "loginnode.***.**"
     default: true
     adapter: "sge"
#   cluster: "cluster"
     bin: "/fast/gridengine/latest/bin/lx-amd64"
#   conf: "/etc/default/gridengine"
     sge_root: "/fast/gridengine/latest"
     libdrmaa_path: "/fast/gridengine/latest/drmaa/lib/lx-amd64/"

I greatly appreciate your help on this matter.


You can look at /var/log/ondemand-nginx/$USER/error.log for the commands we’re issuing and perhaps any error you may be seeing.

If you don’t see any errors - try to replicate the same command on that server. That’s the important bit, when you’re testing these commands you should issue them from the same server where OOD is running.

Ok, I finally came around to do some more testing on this project.
First of all thank you, the error.log helped me to see where that the portal is trying to send qsub commands via port 6444 which isn’t the one we’re using.

I’m guessing for this to change I need to reference the conf configuration file in the cluster.yml.
Should that be the case could you be so kind to tell me which config file/files its exactly looking for? (hot guess would be sge_conf)

Otherwise, perhaps you might have another hint for me. Usually for all our machines we run a source /smth/smth/ command at startup which contains all our configurations for GridEngine.
Is there any way of telling OOD to use that script instead?
(NOTE: It isn’t currently running on my test system so perhaps that might even be the reason why it defaults to port 6444).


sge_conf is a likely bet here, though I’m not sure how to make the binaries aware of it. Apparently the conf parameter is not used at all (just filed an issue for that). Maybe if it’s under sge_root, though I can’t say for sure.

You may want to use bin_overrides to use wrapper scripts instead of the actual command. In such a wrapper you may set the appropriate environment variables, or indeed source that file.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.