Ansible install isn't respecting /var/www/ood/apps/sys

Centos 7.7
OOD 1.7.14
Good Morning, I am having a weird issue and not sure where to look for the solution. I recently tried installing OOD with the ansible setup. Everything worked (more or less) except a few minor tweaks. I took the same apps we use in our dev environment and moved them to the new instance but no matter what I do they don’t show in “interactive apps”. Tried reinstalling without Ansible and still have the same issue. Thoughts?


Scratch that I am dumb.

Needed to change the form.yml to specify the correct cluster… durp…

(Incase anyone needs this):
Ensure you change the cluster in:

1 Like

It could be as simple as needing to restart your PUN (from a dropdown up at the top right to ‘restart web server’). Or you could have the wrong permissions. A regular user should be able to read those files. Or, they use a cluster (in their form.yml) that doesn’t exist (which you’ve indicated). I’m leaving all this here just so other folks can see these 3 common issues.

While we’re on the topic, of Ansible and applications, the role can pull applications from Git. So if you have your applications in github (as we do) you can simply clone them into the appropriate locations. That way you can save the correct configurations and then deploy the corrected version.

If you needed to change something in the role, PRs welcome!

Appreciated Jeff! I was just about to ask you that in a different post. This is a great addition!

Also, when I clone and install with ansible from the repo it seems to prefer 1.6.22, I think it was just a ‘yum repo’ caching issue but just wanted to confirm.

You just reminded me to pull in the PR for updates to 1.7. Yea 1.6 was the default (which you can change). But yea, now it’ll install the 1.7 repo, install latest and update the cache.

Feel free to open tickets on the Github repository directly too!

Excellent will do! Thanks so much