Could not launch virtual desktop

Hi
I’m connecting school server from a mac mini M1 desktop using ondemand portal. I can create interactive desktop without issue, but when I launch it, pop up noVNC tab says ‘fail to connet to server’.
For the record it worked once, but somehow it stoped working after I reopen my browser(Chrome).

Can anyone help with it? I’m very new to this, thanks!

Hello and welcome!

Just so I have the sequence down correctly: you launched a noVNC app previously and logged in and it worked.

For the second login did you try to use the session you had created previously and try to use the connect button again for it? If so this may have failed because you reopened the browser and this would possibly change that session information that the noVNC client is trying to use to connect you that was previously created.

Or, did you go through the process of launching the app again and trying to connect but it failed? This may be a bit more involved if so.

Hi travert,

Thanks for reply!
Actually I found solution on this forum already. The problem is caused by xfce using ‘conda dbus’ instead of system installed one. I deactivated conda and I can use virtual desktop again!