Customised application deployment

Hello team, I am currently testing an IGV application on the OpenOndemand development environment. I have cloned the git repository and updated the config form.yml. I am confident that the cluster name is correctly matched. However, when I tried to launch the application, I encountered an error as attached. I would greatly appreciate it if someone could assist me in identifying the problem. Thank you.

Hello and thanks for posting!

Could you share the submit.yml.erb file that you have with this app? That would help as it looks like there is an issue submitting to the correct cluster and we need to see that to understand why.

This is the submit.yml.erb

  template: vnc
         nodes: "1:ppn=<%= num_of_cores %>"
         mem: "5gb"

Please ensure the submit.yml.erb is formatted when you post it so we can check the syntax. Right now what you have posted is clearly bad yml but I have a feeling that’s not what the file actually looks like.

Also, please post the form.yml.erb as well.

For the cluster you are submitting to, where does that file sit and how have you named it?


cluster: "appliance"
  - modules
  - bc_num_hours
  - bc_email_on_started
  - num_of_cores
  modules: "igv/2.8.2"
    min: 1
    max: 8
    step: 1
  num_of_cores: 1

The cluster name is matched from the file in /etc/ood/config/clusters.d/slurm.yml, I realised that the yaml file name should be the cluster name, this is weird, given that the cluster name is already explicitly defined within the YAML file. So it seems we have to name the yml file same with the cluster name here, is it right?

The cluster name issue has been solved, I got an error message when I launch that application:

Slurm expects you to supply arguements to native through an array. Should be something like this (I think you’re using PBS notation with ppn?)

     - "-n"
     - "<%= num_of_cores %>"
     - "--mem" 
     - "5gb"

Thank you so much @jeff.ohrstrom, this did fix the issue, I have new problem of not load modules, could you please point to where and how should I install that module?
This is the output file

Setting VNC password...
Starting VNC server...

Desktop 'TurboVNC: appliance-compute-0.novalocal:1 (kenny)' started on display appliance-compute-0.novalocal:1

Log file is vnc.log
Successfully started VNC server on appliance-compute-0:5901...
Script starting...
Starting websocket server...
The system default contains no modules
  (env var: LMOD_SYSTEM_DEFAULT_MODULES is empty)
  No changes in loaded modules

The system default contains no modules
  (env var: LMOD_SYSTEM_DEFAULT_MODULES is empty)
  No changes in loaded modules

++ xfwm4 --compositor=off --daemon --sm-client-disable
xfwm4: Unknown option --daemon.
Type "xfwm4 --help" for usage.
++ xsetroot -solid '#D3D3D3'
++ xfsettingsd --sm-client-disable
WebSocket server settings:
  - Listen on :44258
  - No SSL/TLS support (no cert file)
  - Backgrounding (daemon)
Scanning VNC log file for user authentications...
Generating connection YAML file...
Lmod has detected the following error: The following module(s) are unknown:

Please check the spelling or version number. Also try "module spider ..."
It is also possible your cache file is out-of-date; it may help to try:
  $ module --ignore_cache load "igv/IGV_2.16.2"

Also make sure that all modulefiles written in TCL start with the string

No modules loaded
++ igvtools_gui.command
/home/kenny/ondemand/data/sys/dashboard/batch_connect/dev/igv/output/aecd71d5-d134-4d57-a1be-945a9fca63f5/ line 81: igvtools_gui.command: command not found
/home/kenny/ondemand/data/sys/dashboard/batch_connect/dev/igv/output/aecd71d5-d134-4d57-a1be-945a9fca63f5/ line 82: command not found
Cleaning up...
Killing Xvnc process ID 248605
++ xfce4-panel --sm-client-disable
Unable to init server: Could not connect: Connection refused
xfce4-panel: Cannot open display: .
Type "xfce4-panel --help" for usage.

I’m not quite sure how to answer that as it’s a bit specific to your center. I don’t maintain our modules at OSC (that’s handled by another team).

I would reach out to the person on your team/organization that handles module installation (or has done so in the past). That and that lmod official documentation should get you there.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.