No modules loaded issue on dev environment

Hello everyone,
I’m currently working on deploying IGV within our Open OnDemand 3.0.1 environment. However, I’ve encountered some issues with the modules not being loaded. I would greatly appreciate it if someone could provide assistance with this matter. I’ll be attaching the YAML files and output in my next replies.

Thank you.

This is form.yml

cluster: "slurm"
    value: 1

    label: Number of CPU
    value: 1
    min: 1
    max: 24
    step: 1

    widget: "number_field"
    label: Memory per CPU (GB)
    value: 4
    min: 1
    max: 128
    step: 1

    widget: select
    label: Partition
      - ["compute", "compute"]

     widget: select
     label: "igv 2.16.2"
     help: "This defines the version of igv you want to load."
       - [ "2.16.2", "igv/IGV_2.16.2" ]

  - modules
  - bc_num_hours
  - bc_partition
  - bc_num_slots
  - bc_num_mems
  - bc_email_on_started


  template: "vnc"
    - "-N 1"
    - "-n <%= bc_num_slots.blank? ? 1 : bc_num_slots.to_i %>"
    - "--mem-per-cpu=<%= bc_num_mems.blank? ? 4 : bc_num_mems.to_i %>G"
    - "--partition=<%= bc_partition %>"
    - "--time=<%= bc_num_hours.blank? ? 1 : bc_num_hours.to_i %>:00:00"
    - "--job-name=ood-igv"


#!/usr/bin/env bash

# Clean the environment
module reset

# Set working directory to home directory
cd "${HOME}"

# Launch Xfce Window Manager and Panel

  export SEND_256_COLORS_TO_REMOTE=1
  export XDG_CONFIG_HOME="<%= session.staged_root.join("config") %>"
  export XDG_DATA_HOME="<%= session.staged_root.join("share") %>"
  export XDG_CACHE_HOME="$(mktemp -d)"
  module restore
  set -x
  xfwm4 --compositor=off --daemon --sm-client-disable
  xsetroot -solid "#D3D3D3"
  xfsettingsd --sm-client-disable
  xfce4-panel --sm-client-disable
) &

# Start your GUI app

# Load the required environment
module load <%= context.modules %>
module list
set -x

# Launch your GUI app
igvtools_gui.command &


Setting VNC password...
Starting VNC server...

Desktop 'TurboVNC: appliance-compute-0.novalocal:1 (kenny)' started on display appliance-compute-0.novalocal:1

Log file is vnc.log
Successfully started VNC server on appliance-compute-0:5901...
Script starting...
Starting websocket server...
The system default contains no modules
  (env var: LMOD_SYSTEM_DEFAULT_MODULES is empty)
  No changes in loaded modules

The system default contains no modules
  (env var: LMOD_SYSTEM_DEFAULT_MODULES is empty)
  No changes in loaded modules

++ xfwm4 --compositor=off --daemon --sm-client-disable
xfwm4: Unknown option --daemon.
Type "xfwm4 --help" for usage.
++ xsetroot -solid '#D3D3D3'
++ xfsettingsd --sm-client-disable
Lmod has detected the following error: The following module(s) are unknown:

Please check the spelling or version number. Also try "module spider ..."
It is also possible your cache file is out-of-date; it may help to try:
  $ module --ignore_cache load "igv/IGV_2.16.2"

Also make sure that all modulefiles written in TCL start with the string

No modules loaded
++ igvtools_gui.command
/home/kenny/ondemand/data/sys/dashboard/batch_connect/dev/igv/output/e8d1ac34-743e-4ad0-ad89-af8c610364e2/ line 81: igvtools_gui.command: command not found
/home/kenny/ondemand/data/sys/dashboard/batch_connect/dev/igv/output/e8d1ac34-743e-4ad0-ad89-af8c610364e2/ line 82: command not found
WebSocket server settings:
  - Listen on :63028
  - No SSL/TLS support (no cert file)
  - Backgrounding (daemon)
Scanning VNC log file for user authentications...
Generating connection YAML file...
Cleaning up...
Killing Xvnc process ID 246405
++ xfce4-panel --sm-client-disable
Unable to init server: Could not connect: Connection refused
xfce4-panel: Cannot open display: .
Type "xfce4-panel --help" for usage.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.