Data-option-for option does not work

Dear all,

I use OnDemand version 3.0.3 and want to use the data-option-for option in form.yml as follows.

form:
  - node_type
  - software
attributes:
  node_type:
    widget: select
    options:
      - "standard"
      - ["gpu", "gpu", data-option-for-software-1ABC: false]
  software:
    widget: select
    options:
      - "1ABC"
      - "AABC"

If I selected “gpu” for the node_type, I expect not to select “1ABC” for the software, but I can select it. This problem seems to occur when the first character following data-option-for-software- is a number.

The example above is quite simplified. Since I am actually using a hash managed by spack, I would like to use a number at the beginning of the character.

Thanks,

This could be a bug on our side. I’ll file a ticket upstream and see what’s what.

I’ve confirmed this is a bug and am patching it in 3.1.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.