File cannot be browsed in Job Composer

I was able to submit a job through Job Composer of OOD-2.0.28-1. However, I noticed that the Job Composer page might be a little strange. I haven’t changed anything in myjobs application.

Nothing is displayed in “Folder Contents:”.
If you look at the URL below, you should see the files in that directory.
Also, the “Submit Script” field is missing.
Furthermore, “Open Terminal” in my page is translucent and cannot be clicked.

Can you please advise?
Best,

Hi Masahiro.

Thanks for the post. I will look into this today.

Thanks,
-gerald

Hi Masahiro.

One quick question. Do you experience this same behavior when using the “Files” app from the Dashboard?

Thanks,
-gerald

Thank you for your prompt response.

Do you experience this same behavior when using the “Files” app from the Dashboard?

No. I can see all files in Files app.

And in the Job Composer page for my created template, it looks fine.

However, the first page of Job Composer is odd.

Thanks

I found the cause of my problem.
In /etc/ood/config/apps/myjobs/env, I write the following settings.

OOD_DATAROOT=${HOME}/.ondemand/myjobs

It seems that if there is a dot in the directory name, it will not work correctly.

Thanks for the update @mnakao!

I’ve created the bug upstream for the same.

1 Like