Hostname issues on new OOD installation

We can test the OOD with our test host and all appears to function.

However, when trying to change the host name of the website, it produces an error.

I have tried to modify /etc/ood/config/ood_portal.yml by adding the servername and proxy_server with the CNAME of the OnDemand server. I rebuilt the portal with /opt/ood/ood-portal-generator/sbin/update_ood_portal and restarted the services httpd and ondemand-dex.

I am getting a 500 error in that case. Before the changes, if I go to the FQDN of the server, I get the login page. I need OOD to recognize a CNAME and use it. Is there some documentation for using CNAMES with OOD ?

I use CNAMEs with no problem, viz:

$ host ondemand.hpc.arizona.edu
ondemand.hpc.arizona.edu is an alias for ood.hpc.arizona.edu.
ood.hpc.arizona.edu has address 128.196.131.30

My ood_portal.conf has no knowledge of the ondemand.hpc.arizona.edu CNAME EXCEPT for that string bring listed in the SSLCertificateFile as a Subject Alternative Name (SAN), viz:

            X509v3 Subject Alternative Name:
                DNS:ood.hpc.arizona.edu, DNS:ondemand.hpc.arizona.edu

Cheers,
Ric

Thanks Ric,
How did you do that?
Where do I need to make changes in OnDemand?
I would expect the site needs a base URL for rewrites?

My test site appears fine before any changes.
But when I added the CNAME, it no longer worked.
I have not started using SSL yet, that’s next.

To verify this behavior, I wiped out the vm and started from the beginning.
The host FQDN is whqrhel801p.sfwmd.gov
The CNAME is rhel801.sfwmd.gov

— Started completely fresh with these steps:

  useradd ood
  id ood
  dnf module enable ruby:2.7
  dnf module enable nodejs:12
  yum install ondemand
  yum install ondemand-dex 
  systemctl start ondemand-dex
  systemctl start httpd

When I go to the FQDN site, it looks like a normal OOD login
When I go to the CNAME, I get a 500 error.

Certainly, OOD needs to be informed about the URL changes.
I just need to know where to change it so the CNAME works.

what can I say? ood at my site knows nothing about the CNAME, EXCEPT in the SSL certificate. If you don’t have both names in your SSL cert, a 500 error would not surprise me. The other thing to check is that the “host” command resolves the CNAME to the real name, and the real name to the IP of the server.

Hi Ric,
No problem. I appreciate any insight from veteran OOD users.
Thanks for your responses.
:grinning:

servername here is the only relevant config, and it should work directly being a DNS CNAME. That’s how OSC works too if I dig our production site. Use proxy_server only when you’re behind a proxy, otherwise just leave it commented.

Now to the actual issue - we’ll have to see the log entries of your 500s to see what the error could be.

Thanks Jeff,
I have reverted back to my previous config of OOD. It works now.
Going to re-read the customization section in the docs.
I appreciate everybody’s input here. Thanks much !