Internal Server Error on CNAME

I’ve setup OOD v3.1.4 on a rocky 9 vm. OnDemand is setup with dex with ldap connector.

Below is my setup with redacted fqdns.
SSL enabled: true
servername: (actual server fqdn)
serveralias: (cname record pointing to

When visiting via the browser. Everything works seamlessly from firefox, or safari but, does not work in google chrome. I have tired clearing cache, incognito mode but it still does not work. All I get is Internal server error and the url does not seem to be re-writing to The error tha I get is just internal server error and the address bar field seems to be redirecting to instead of

Any help would be appreciated. Thank you

Hello and welcome! Sorry to hear about the trouble.

What version of chrome are you running?

Have you tried on another version of Chrome?

Do you have any extensions in chrome that would interfere which you may not have realized were on?

The next best bet is to use the Chrome Developer Tools (F12 button in the browser), go to the Network tab and examine the request as you make it to see if you can spot any errors or redirects that would clue you in more.

Hi Travis,
The version on my

  1. linux box is 124.0.6367.60 (x86_64)
  2. Mac is 124.0.6367.119 (arm64)
    I thought it could be some extensions too… so, I tried it on my wife’s laptop which I know for sure she has no extensions enabled.
    I did the F12 in chrome and I see this and a 302 found and favicon.ico 404

Hope it’s useful. And thank you for looking into this.