How to set env variable? In order to fix: [] not found for current Ruby interpreter

Every time I login, my error log shows the error messages. It says it can be fixed by setting PASSENGER_DOWNLOAD_NATIVE_SUPPORT_BINARY=0. What file can I put that in, so it affects all users?

As an aside, I do see the library in: /opt/ood/ondemand/root/usr/share/ruby/vendor_ruby/ But apparently it can’t find that?

App 3153123 output: [] not found for current Ruby interpreter.
App 3153123 output: This library provides various optimized routines that make
App 3153123 output: Phusion Passenger(R) faster. Please run ‘sudo yum install passenger-devel-6.0.14’
App 3153123 output: so that Phusion Passenger(R) can compile one on the next run.
App 3153123 output: [] finding downloads for the current Ruby interpreter…
App 3153123 output: (set PASSENGER_DOWNLOAD_NATIVE_SUPPORT_BINARY=0 to disable)
App 3153123 output: Could not download\
t-ruby-2.7.0-x86_64-linux.tar.gz: The requested URL returned error: 404
App 3153123 output: Trying next mirror…
App 3153123 output: Could not download\
14/rubyext-ruby-2.7.0-x86_64-linux.tar.gz: The requested URL returned error: 404
App 3153123 output: Trying next mirror…
App 3153123 output: Could not download\
.14/rubyext-ruby-2.7.0-x86_64-linux.tar.gz: The requested URL returned error: 403 Forbidden
App 3153123 output: [] will not be used (can’t compile or download)
App 3153123 output: → Passenger will still operate normally.

Are you on an OS that you can get a nightly from? That’s going to be a lot less painful for Ubuntu users. Offhand, I’m not sure what’s causing that, but I can take a look.

I’m using Ubuntu, and the problem was somewhat discussed on github:

I accidentally left out the last line of the error log, which shows it’s being triggered by dashboard.

App 3161996 output: [2022-07-13 13:57:14 -0400 ] INFO “method=GET path=/pun/sys/dashboard/files/fs/home/mrl format=html controller=FilesController action=fs status=200 duration=108.20 view=86.01”

In any event, in that previously discussed situation, Ruby wasn’t trying to download the native support library. For us it is. So it would be nice to block that by setting that var.

Well I’d say that the root cause is that it can’t find the libraries ( when it should be able to. The ansible role should have built that so and put it in a location that OOD can find.

Are you able to use a nightly .deb instead? I feel like that’s going to be more stable than building from the source.

Jeff - I did do an install from the deb about a month ago, not the sources. In any event, this issue is not significant. The person I’m helping here at MIT with the install is John Wright, and I think he’s going to be submitting issues, now that we at least got it partially running! - Mark

Oh OK good deal. Yea we fixed that issue at some point, so an update would get rid of that.