Install OOD on IBM Power System

Dear All,

I am trying to install OOD on IBM Power system (ppc64le). Is there a way to install OOD rpm free?

Thank you in advance,

1 Like

While possible (probably), we’ve never installed on non-rpm systems. So it would be breaking new ground.

You could try the containers we have on Dockerhub or on this repo for the source of those images. Though they are not meant to be production systems, they could give you and idea of all the things you’d need to install by hand.

Sorry, I didn’t even realize that you’re on a different processor architecture. We only currently build x86_64 versions.

Seems like you’d have to rebuild using docker buildx build --platform linux/ppc64le or rebuild the image starting from ppc64le/centos:7.

I’m sorry we don’t have better options for you.

Thank you so much for your reply. If the openondemand can install on ppc64le then it should be able to installed natively right? I would like to try if I can manage to install the openondemand on ppc64le RedHat/Centos, any guidenace will be appreciated.

Thank you again for your reply. I had tried to build a container of OOD with the docker file you provided. However, the installation failed with following error meassge

  1. Cannot find a valid baseurl for repo: centos-sclo-sclo/ppc64le

  2. [Errno 14] HTTPS Error 404 - Not Found

I am wondering if there has anyway that we can build the OOD from scratch?

Thank you in advance,

Sorry, I’ve got bad advice then bad news for you.

I’m trying to get an Ansible playbook working (for other distributions too), but it’s not easy and I don’t know how much time I have to commit to it.

The tricky bit is having the other dependencies reliably installed. You need apache httpd 2.4, ruby 2.4, nginx 1.4, nodejs 6 and phusion passenger 5.3. Then they all need to connect and get configured.

As a side note, are you running Linux or AIX?


Thank you so much for your reply.

We are using is IBM Power System AC922, along with CentOS-7.5.


Hey, got a small update.

I’m working on the playbooks and super close to getting something to boot correctly.

The update I have for you specifically is that phusion passenger, a major dependency we have, only builds for x86_64, x86, and i386. I’ll be sure to setup a way to just grab a tar locally, but I’m afraid you’ll have to make and tar these dependencies.

On package cloud they have i386, but no ppc64le

SCL does not provide packages for PPC architectures, at least not for CentOS. It should be possible to take the SRPM used by SCL and rebuild it using mock configs for ppc64le. The passenger currently used by OnDemand is built using a heavily modified passenger build environment. I am evaluating if it’s possible for OnDemand to provide PPC packages.


have you thought about running OOD on an x86 server with P9 system specified as a cluster in /etc/ood/config/clusters.d/foo.yml instead? I was thinking that approach for a P9 system at MIT. We haven’t tried it yet, but it seems like if P9 filesystems are mounted to OOD filemanager target then it should work - at least that is what I am hoping!


Thank you so much for your help, our system had a hardware issue these days and I will working on the OOD later today.



Thank you so much for your help and I will try you suggestion first and let you know if I had any further trouble.



Hi Chris,

We did install the OOD on an x86 machine along with our P9 system. However, there are some issues like how to pass the P9 terminal session we can not solve. So I am very interested and willing to invest some time to install OOD on P9 system, I will work on @jeff.ohrstrom suggestion first and let you know if it is working.



@superdavidxp the Ondemand ansible role is now on Github, it can build open ondemand from the source. I can already guarantee you’ll need to update your system Ruby since it relies on the OS ruby (for now) which in centos I think is ruby 2.0. You’ll need ruby 2.4 and nodejs 6.

Also, it should be said, as it is in the README, this is still a work in progress. The runs I’ve been using last week and today produce some zombie process’. Which is to say, this install procedure is not yet production ready, not by a long shot.