Issue Enabling App Development

Currently using the 2.0 version of Open OnDemand, and the instructions found here for enabling app development isn’t working.

I’ve created the symlink so OnDemand will be able to find the users app and created the actual dev directory for the user inside of their ondemand folder.

Unfortunately, the user isn’t able to see the Develop dropdown. Any ideas on how to fix this?

Hi and welcome!

Be sure to restart your PUN after the changes (the Restart Your Webserver link in the Help dropdown menu).

If the symlink is created correctly and the PUN restarts to pick up the change - I think those are the only 2 things that could affect this.

Hello, unfortunatly restarting the PUN after the changes did not work. I even tried to remove the symlink and recreate it. Logging out fully, waiting a little while, logging back in, and then restarting the PUN but it still isn’t showing up.

Here’s how I created the link inside of /var/www/ood/apps/dev/username :

ln -s /home/username/ondemand/dev gateway

In the link I can see the users directory, so I’m not sure what’s going on.

Then I would ask if the top level directory has the right permissions - looks like we set it to 755. Maybe it’s not permissive enough?

[~()]  ls /var/www/ood/apps/dev/ -lrta | grep johrstrom
drwxr-xr-x  2 root root 4096 Jul 31 10:10 johrstrom

The top level directory does have the correct permissions, 755.

Did you change the nginx_stage.yml configuration app_root? If you changed the app root location, then this may have affected this.

Additionally, did you change any other configurations that could be setting this? That is, is it working for everyone but this user, or has it never worked at all?

It’s working for some users, but there are a handful of users that it doesn’t work for. There hasn’t been any changes to that configuration file. I’m not sure what’s causing this issue. Considering it works for some users.

OK - then I’d ask what’s different about these users?

You said you created the directory for them - I wonder if that’s the issue? If their own ~/ondemand/dev doesn’t have the right permissions/ownership.

The user does own it and they have the correct permissions. I’ve compared the users ~/ondemand/dev directory, there isn’t a difference with these users besides the ownership.

Do you run selinux? I wonder if there’s a denial there.

Are you able to su into the user? I’d try su into that user and start to ls on that directory /var/www/ood/apps/dev/ all the way down to see if that user can navigate through to their own ~/ondemand/dev from the /var directory.