Issues with RedHat8 and XDG settings for desktop applications

Hi. I’m wondering if anyone has had a similar issue in getting VNC sessions started properly when using RedHat 8 cluster nodes.

I’m trying to launch the ‘fiji’ application (though it doesn’t really matter what the end application is), and I’m basing this on the bc_desktop launcher. The main issue is that while the application starts, there’s no window manager and ‘marco’ isn’t launching.

If I ssh into the cluster node, then launch the vnc app through ondemand, it does work with window decorations and all. I had this problem a long time ago with RedHat 7 systems and it came down to the unsetting of these environment variables in


This works fine for RH7 but doesn’t seem to work on RH8 in the same way. Has anyone encountered this?


wondering…does this have anything to do with the systemd --user stuff that might need to be in place for a user on RH8 that wasn’t there on redhat7.

I think I made progress on this issue. I made sure that my RedHat8 system had the ‘dbus-x11’ package installed. Then in my file, I had this:

dbus-launch /usr/bin/marco --no-composite --no-force-fullscreen --sm-disable &

# mate-panel blocks, but does not work reliably when launched in the same subshell as marco
dbus-launch mate-panel &

So I just stuck the dbus-launch in front of the window manager commands and it seemed happy. Just putting it in front of mate-panel wasn’t enough (looks like marco went away). If I just put the dbus launch in front of marco and not mate-panel, the panel doesn’t come up. So, it seems like putting it in front of both was the way to go.

Yea there are a couple of other topics related to RHEL 8 and these xfce scripts we launch (though I see you’re launching MATE instead).

In any case - the gist of them is that becuase of updates from RHEL 7 to 8 some commands don’t work the same anymore. They block and need to be backgrounded or they have different CLI options.

Do you need me to pull those topics for reference?

I had looked at the docs online with the configuration you have for matlab, and tried that as well, but generally had the same issue until I did the dbus-launch. If you can find those topics, it might be helpful as well.


Here are a couple I found off the top of my head. Again though, they deal with XFCE, not MATE, but could be a similar issue as they are also RHEL 7 → 8 migrations.

Yeah, these both are essentially the same solution (dbus-launch), guess my searching wasn’t particularly good.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.