Jupyter App - Connections Failed

I am 90% there with a functioning Jupyter app through OOD, however, the functionality is not there. I can launch the job on our cluster through OOD and open Jupyter in the browser, but I cannot open most directories, connect to ipython, or open a terminal.

I have verified it works through a terminal on a VNC session, so I am assuming it is either our network settings or I am missing something key in the OOD app.

Does the shell app work? I mean the shell app we ship with OnDemand?

I ask because both of these rely on websockets. I’d ask if you have a proxy in front of OnDemand and if it has websockets enabled.

The shell app works but only for the head node, and we do have websocks working I am told since NoVNC uses it.

Then you’re going to have to dig into the developer tools of your browser to see what’s going on. either in the network tab to see what the responses from the server are or in the console tab to see what client side javascript errors there are.

1 Like

Oh I also see this. See how you’re localhost’s URL path is directly /notebooks and when you connect through OOD there’s /node//

Are you setting this jupyter configuration - base_url?

I have it set similarly to the osc release.
Thanks, I have our admin team digging in now. I just wanted to make sure it wasn’t something obvious.

umask 077
cat > "${CONFIG_FILE}" << EOL
#c.KernelSpecManager.ensure_native_kernel = True
c.NotebookApp.ip = ''
c.NotebookApp.port = ${port}
c.NotebookApp.base_url = '/node/${host}/${port}/'
#c.NotebookApp.port_retries = 5
c.NotebookApp.password = u'sha1:${SALT}:${PASSWORD_SHA1}'
#c.NotebookApp.open_browser = False
#c.NotebookApp.allow_origin = '*'
c.NotebookApp.notebook_dir = "$NOTEBOOK_ROOT"
c.NotebookApp.disable_check_xsrf = True
#c.LabApp.check_for_updates_class = "jupyterlab.NeverCheckForUpdate"

We solved it, thank you. We just needed to update our proxy settings in the ood_config.yaml

Thanks again for the help!