JupyterLab Installed

A user requested JupyterLab and we are running Jupyter Notebook. I see from the docs that JupyterLab is the newer version of Notebook. I see online that Pitt has it installed. Do any other sites? Does OSC plan to support this upgraded version of Jupyter Notebook?

TIA - Susan Litzinger

Susan: We already have this running in production at OSC (see screenshot below, where you can select a checkbox to run JuptyerLab instead of the Notebook). I’m sure this is already in the repo somewhere that you can grabd it, but I’ll defer to one of my colleagues to point to the specific location.

Yea it comes down to this line in the boot command where we toggle juypter lab or jupyter notebook.

I imagine you would just need to add that toggle to your form.yml, and the script and ensure the dependencies are installed/enabled on your compute nodes.

Hope that helps - let us know if there’s anything more about this you need.

@susan were you able to update your Jupyter application?

For version v1.6.22, this is how I got JupyterLab working by:

  • Adding this to form.yml

- jupyterlab_switch

    widget: "check_box"
    value: 1
    label: Use JupyterLab instead of Jupyter Notebook?
    help: |
      JupyterLab is the next generation of Jupyter with an IDE-like experience, and is completely compatible with existing Jupyter Notebooks.
  • Changing the last line of template/script.sh.erb to this

jupyter <%= context.jupyterlab_switch == "1" ? "lab" : "notebook" %> --config="${CONFIG_FILE}" <%= context.extra_jupyter_args %>

Based upon:

1 Like

How do I set the JupyterLab checkbox to unchecked? I tried changing the value field value: 1 to value: 0 but that hasn’t worked.

I did a search for ruby erb form.yml check_box, found a RoR page that looked about right and tried adding unchecked_value: 0 without success.

We are still in the beta/testing phase of the rollout, and my preference would be for prospective users to drop to a Jupyter Notebook initially, rather than a Lab interface.

Any tips on unchecking the jupyterlab check box would be appreciated.

check_boxes use checked_value not just value. I ran into the same issue recently.

1 Like

Perfect. Thank you, worked first time. Can’t believe I tried unchecked_value but not checked_value.