Open OnDemand 3.0

Hello team, I attempted to update openondemand using an ansible playbook. However, I encountered an issue where it states that there is no available package for ondemand-3.0.1. I also tried ondemand-3.0.0, but faced the same result. Strangely, ondemand-2.0.29 works without any problems. Can someone kindly shed light on what might be happening in this situation?

Hi and welcome!

I said a similar thing on slack, but will say it here in case anyone else sees it.

One thing that’s important to note is that the ansible role’s versions correspond to the OnDemand version it’s trying to install. So the role’s version 3.0.x will install OnDemand version 3.0.x.

Beyond that, I’d verify what you have rpm_repo_url set to (if your installing on EL, there’s a similar configuration for Ubuntu systems) and if it’s the right repo url for 3.0. Again, 3.0.x of the ansible role will default to the correct url.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.