Proper file location to set nginx parameters

Some of our users are getting the message “queue full” when trying to start additional OOD applications. After some research, we found that the parameter passenger_max_request_queue_size could be used to increase the size. There are other parameters to consider to better fine tune the passenger application; however, it’s not clear where is the correct place to set them. They could be added as environment variables in the per user PUN configuration file ( /var/lib/ondemand-nginx/config/puns/%{user}.conf ), by changing the template OOD uses to start the process.

Your suggestions and guidance are appreciated.

Hi Ruben.

Thanks for the post and welcome to the Open OnDemand Community.

In regards to your question. Please see the following documentation, specifically around

passenger_options

https://osc.github.io/ood-documentation/latest/reference/files/nginx-stage-yml.html

If that doesn’t help, please let us know so we can help you get to the solution that you need.

Thanks,
-gerald

Thanks, Gerald. I think that would be right place to put these parameters.

Unfortunately, when I sent them, I get this message from the portal:

Error – undefined method `starts_with?’ for “passenger_max_preloader_idle_time”:String

Did you mean? start_with?

Run ‘nginx_stage --help’ to see a full list of available command line options.

I’ve already tried all the combinations I can think of, without success.

This is what I added to the nginx_stage.yml file:

passenger_options:
    passenger_max_preloader_idle_time: 300

Any suggestions?

Thanks,

I think your entry will be like this:

passenger_options:
  passenger_max_request_queue_size : 10

You will need to be very careful, as it is yaml, and yaml is extremely sensitive to layout. Especially around spaces and tabs. So, you will want to ensure you are using spaces and not tabs. You probably already know this, but just want to cover all basis.

Thanks,
-gerald

You’re running into a bug. You’ll have to patch that file /opt/ood/nginx_stage/lib/nginx_stage/configuration.rb. 2.0.28 has this bugfix, but it won’t hit the public repository until sometime next week.