Shell access timeout

Hi All,

Our shell access app times out too quickly after only a couple of minutes of being inactive.
How can we have it fixed so users don’t have to frequently restarting the app?
We are using V1.8.18

TIA!

Delilah

Hello and welcome!

The first thing I’d be curious to know is what is the actual setting on the server for timeouts?

You can find this in the session with, assuming bash shell:
grep -i alive /etc/ssh/ssh_config

Hi Travis,

Thanks for your response.
Here is what I get.
ServerAliveCountMax 3
ServerAliveInterval 60

Do you have a suggested value?
On my local ssh, I usually set ServerAliveInterval 120, it almost never logs me out on short notice.
Do you suggest the same on our server setting? I am curious what other sites do to prevent kicking people out too often?

Best,
Delilah

The easiest thing to test would be to cut the ServerAliveInterval in half to start.

Increasing the ServerAliveCountMax to something higher is a good bet too, though that I don’t have a good upper bound on that number aside from suggesting 10 to start.