Shell app support mobile use?


Our user is reporting that the shell app cannot be used on ipad since no keybboard is invoked when trying to input password. Does it natively not support mobile use?

Thank you and look forward to your reply.

Best wishes,
Kaiyue Wu

Unfortunately it doesn’t offer mobile support. However there is another way to access the linux command line from your iPad. There’s this app called iSH which allows you to do that.

If you want, you can read this article and it’ll help you set it up:
Run the Linux command line on your iPad |

@wooloo1121 what web browser are you using on the iPad?

To clarify it might work with other browsers on the iPad than Safari. I thought it never worked on the iPad because of the very issue you mention. However, several of the interns that work on my team, OSU students, claim they are able to use the shell app and a keyboard appears for them. It is possible though that this is because they do not see the password authentication prompt. We setup trust between the login nodes and the web host so a user’s process can ssh to the login node without requiring authentication.

Hi @efranz, thank you so much for the reply. We tried edge and chrome, it doesn’t work on them.

Hi @omerzulfiqar, thank you so much for the suggestion.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.