SLURM initial config and testing

I am somewhat confused by the documentation for getting OnDemand to use SLURM.
The authentication issues have been resolved :smiley: So now I need to get SLURM working.

I added the SLURM config in /etc/ood/config/clusters.d/

---
v2:
  metadata:
    title: "Flow Cluster"
  login:
    host: "whqhpc-login01p.sfwmd.gov"
  job:
    adapter: "slurm"
    bin: "/usr/local/bin"
    conf: "/etc/slurm/slurm.conf"
    # bin_overrides:
      # sbatch: "/usr/local/bin/sbatch"
      # squeue: ""
      # scontrol: ""
      # scancel: ""

SLURM was installed from RPMs (generated from rpmbuild).
It all works on the command line. I can run sinfo, srun, sbatch, etc without any issue.

I tried to run the configuration test in the docs.

I am getting this:

$ bin/rake -T test:jobs
Could not find rails-5.2.6 in any of the sources
Run `bundle install` to install missing gems.

Note that this is RHEL 8, no scl involved.
How do I apply and/or test this configuration ?

Hi Equiros,

Thanks for the post. I will investigate and let you know what I find.

Thanks,
-gerald

@equiros-sfwmd ,

Did you install slurm?

Thanks,
-gerald

Of course !
the other SLURM commands all work
I can srun, sinfo, squeue, sbatch from the command line.

Sorry. Just covering my basis before digging into this.

No worries :smiley:
Thanks for your help

One other question. What happens when you run “bundle install” ?

If I try to run bundle install as root, it says:

Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this
application for all non-root users on this machine.
Could not locate Gemfile

If run as an unprivileged user:
Could not locate Gemfile

Hi Equiros.

After consulting with my colleague. This may be as simple as doing the following:

source /opt/ood/ondemand/enable

YES !

That works now, Thank you very much !

1 Like

Thanks Equiros.

We will be updating the documentation to reflect this requirement if not use scl.