VMD on Mate Desktop in OOD 1.5.5 - NVIDIA driver issue

Our cluster offers users a number of visual applications that our users are loading as Linux software modules and running on the Mate Desktop. Most of these are running without issue, but we have discovered that one such application, Visual Molecular Dynamics (VMD 1.9.3) is not using the NVIDIA driver and is reporting the following error when the application is started from the terminal shell window:

/hpc/applications/vmd/1.9.3/ogl/lib/vmd/vmd_LINUX64: /lib64/libGL.so.1: no version information available (required by /hpc/applications/vmd/1.9.3/ogl/lib/vmd/vmd_LINUXAMD64)

The application still produces a display, but the message would seem to mean that it is trying to use the libGL.so.1 library (actually a symlink to the libGL.so.1.7.0 library) that is supplied by the libglvnd-glx package rather than using the NVIDIA driver. We saw something similar a couple of years ago when we were installing the DCV product from NICE Software. They had us deal with it by copying a custom libGL.so.9999.9999.9999 to the system and then recreating the libGL.so.1 and libGL.so symlinks with links to the custom library. (I tried copying that same file to my Mate Desktop system, but no dice!) Is anyone else using this application in a Mate Desktop accessed via OOD?

Our environment:
VMD 1.9.3 (OpenGL)
Open OnDemand 1.5.5
CentOS 7.4 / 7.5 (have tried both)
Linux Kernel 3.10.0-693.21.1.el7.x86_64 / 3.10.0-862.14.4.el7.x86_64
NVIDIA Quaddro M5000 with x86_64 drivers 390.116, 418.43, 440.44, and 440.59 (have tried each)

Full text output when running VMD:

$ vmd
/hpc/applications/vmd/1.9.3/ogl/lib/vmd/vmd_LINUX64: /lib64/libGL.so.1: no version information available (required by /hpc/applications/vmd/1.9.3/ogl/lib/vmd/vmd_LINUXAMD64)
Info) VMD for LINUXAMD64, version 1.9.3 (November 30, 2016)
Info) VMD - Visual Molecular Dynamics
Info) Email questions and bug reports to vmd@ks.uiuc.edu
Info) Please include this reference in published work using VMD:
Info) Humphrey, W., Dalke, A. and Schulten, K., `VMD - Visual
Info) Molecular Dynamics’, J. Molec. Graphics 1996, 14.1, 33-38.
Info) -------------------------------------------------------------
Info) Multithreading available, 36 CPUs detected.
Info) CPU features: SSE2 AVX AVX2 FMA
Info) Free system memory: 247GB (98%)
Info) Creating CUDA device pool and initializing hardware…
Info) Detected 1 available CUDA accelerator:
Info) [0] Quadro M5000 16 SM_5.2 @ 1.04 GHz, 7.9GB RAM, AE2, ZCP
Warning) Detected X11 ‘Composite’ extension: if incorrect display occurs
Warning) try disabling this X server option. Most OpenGL drivers
Warning) disable stereoscopic display when ‘Composite’ is enabled.
Info) OpenGL renderer: Gallium 0.4 on llvmpipe (LLVM 3.9, 256 bits)
Info) Full GLSL rendering mode is available.
Info) Textures: 2-D (8192x8192), 3-D (512x512x512), Multitexture (8)
Info) Detected 1 available TachyonL/OptiX ray tracing accelerator
Info) Compiling 1 OptiX shaders on 1 target GPU…
Info) Dynamically loaded 2 plugins in directory:
Info) /hpc/applications/vmd/1.9.3/ogl/lib/vmd/plugins/LINUXAMD64/molfile
vmd >

We are running it at OSC with XFCE. In case you haven’t seen it, we have a repo with info on that, which might provide some insights to you.

@rengland did you reslove your issue? Here’s a little more info about our setup.

We don’t use NVidia/Cuda and I imagine that’s the big difference. You’ll notice our VMD get’s booted from the vglrun command. Another thing about us is that those libraries are in our $LD_LIBRARY_PATH already (under /usr/lib and /usr/lib64) so we don’t have to module load gl libraries, they’re just available.

I’d suggest ensuring the NVidia version of libGL.so.1 is in your $LD_LIBRARY_PATH probably through modules. I’d bet that’s likely where you’ve gone awry.

@rengland were you able to resolve your issue?

You’re also using Xfce, whereas we have been hoping to only need to support Mate in our environment. I my try installing those packages as well and just see what happens. As for CUDA, we do have a version in a module, but on our VDI nodes, I’ve also installed a more recent version of CUDA on the local system.

No, I haven’t resolved it yet. I had to break away from this project to tend to some more urgent and higher-priority tasks, but have been hoping to come back to it soon.

I did try using vglrun, but so far I haven’t been able to get that to display VMD for me. It’s probably just that I need to set some environment variables or include some arguments in my command line.

Hey sorry to keep pinging you on this, but did you have any luck? We’re interested in to have the resolution here in case someone else runs into the same issue.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.