Xfce4 Remote Desktop

Howdy folks,
Happy Holidays :slight_smile: !

A couple of things regarding Xfce4. First, your xfce.sh script contains the following:

Disable startup services

xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled -n -t bool -s false
xfconf-query -c xfce4-session -p /startup/gpg-agent/enabled -n -t bool -s false

That seems to run and work. But when I add a few lines myself they’re completely ignored and never apply:

Default RCI config

xfconf-query -c xfce4-screensaver -p /lock/enabled -n -t bool -s false
xfconf-query -c xfce4-desktop -p /desktop-icons/file-icons/show-filesystem -n -t bool -s false
xfconf-query -c xfce4-desktop -p /desktop-icons/file-icons/show-home -n -t bool -s true
xfconf-query -c xfce4-desktop -p /desktop-icons/file-icons/show-filesystem -n -t bool -s false

I deleted my ~/.cache/sessions and ~/.config/xfce4 folders to make sure a previously saved session wasn’t overwriting the defaults I want. Where can I put these to guarantee they’re set at every login?

While I’m at it, is there a default location where I create default desktop items (links, icons, etc)?

Thanks guys! I realize you’re all on personal leave :slight_smile:

Kenny, MSU RCI

Try to restart the PUN and then submit the job again for the desktop and you should see the changes take effect.

Hi Travis,
Happy New Year, and thank you for respoding.

I’m not sure I follow, is this a manual thing to do? I’m afraid I don’t completely understand the use for nginx_stage.

Kenny

Happy new year!

Yeah, it would be a manual step once you’ve made the changes to see them take effect.

So, to restart a PUN you can use the dropdown menu on the top right you will see a Develop option, and if you select that you can see an option to restart the PUN.

I was able to get your changes to work by restarting, then going back in and resubmitting that the form for the desktop environment to launch.

Once that script is in place though, each launch will respect this. I think you just have to do the restart and resubmit to clear the cache and anything else correctly.

Hi Travis,
Okay I see what you mean now. Running xfconf-query doesn’t really work the first time the desktop is launched because the config xml files haven’t been created yet. The second time you log in all my settings are set properly. You’ll find that xfconf-query changes are on the fly moving forward too.

So I need to create skeleton xml files for the settings I want to copy to the user ~/.config/xfce4 folder. After that the xfce.sh script that launches the desktop takes care of it for me.

Thanks, Travis! Appreciate your help in nailing this down.

Kenny, MSU RCI

Great to hear, and thanks for the summary!