Can't maximize Comsol when in the interactive app but can inside an interactive desktop

We are running comsol 6.0 on rhel8 nodes and when I run the app inside an interactive desktop I can resize the consol window but when I run it as an interactive app alone the comsol window will not maximize or resize at all. Is there something I should do on the command that starts up comsol to make that available? The command we are using to start it up as an interactive is:

comsol -3drend sw

and on a node with vgl

vglrun comsol

It sounds like in the one case you are running it as a vnc app and have access to a window manager while in the other it is the app alone running which doesn’t provide such functionality.

Here’s OSC’s repo for comsol that you can see is using vnc as well, and may prove useful if you haven’t seen it:

it’s the difference in whether you are using a basic or vnc setting in the batch_connect app that is the difference to note. In one case there’s a web server, in the other it’s VNC server.

Hopefully that helps explain some behavior. Are you able to use it as a vnc app?

Yes we are using vnc in both the interactive app connection and the interactive desktop.

Could you share the submit.yml.erb? It would help to know exactly what is being set.

submit.yml.erb.txt (1.7 KB)

Thanks for that. Nothing there is jumping out.

And just to be sure, have you ensure the dependencies are all installed as found in the docs:

It seems like something with TurboVNC might be missing given you can’t resize the window at all.

Yes we have all of those and at versions higher than required.

Are those installed on the web-node or the actual compute node? It doesn’t sound like a window manager is there.

Can you check the log outputs for the sessions to see if you can find something there?

the output.log or the vnc.log would be the first places I’d look to see if something is throwing a warning.

Also, do you see the window manager logging anything under the config directory in the session directory?

I’ve uploaded the output.log and vnc.log which doesn’t really show much and I do not see a session directory under my ~/.config dir.
vnc.log.txt (3.7 KB)
output.log.txt (3.0 KB)

No, the session has a directory created in that same place you retrieved the files you just uploaded that is named config which would have the logs for the window manager.

Do you see that directory in there?

I see. No error messages or any type of messages logged there.

That is very odd. There should be logs there for the window manager, which makes me think it’s not running.

For instance we use xfce so in my session data i have a config/xfce4 directory with logs, but you are saying that doesn’t exist?

If so, you’ll have to look at your logs to find where it’s trying to start the window manager and what it says, and check the install of the window manager because it should have generated that directory and logs.

Yes there is an xfce directory and under it is two directories (terminal, xfconf).

Ok, that’s making more sense.

I looked at the output.log you posted and saw an error immediately that may be part of the problem at the bottom of the log:

(xfsettingsd:2468133): GLib-CRITICAL **: 16:18:50.542: g_str_has_prefix: assertion 'prefix != NULL' failed

(xfsettingsd:2468133): GLib-GObject-CRITICAL **: 16:18:50.543: g_value_get_string: assertion 'G_VALUE_HOLDS_STRING (value)' failed

(xfsettingsd:2468133): GLib-GObject-CRITICAL **: 16:18:50.544: g_value_get_string: assertion 'G_VALUE_HOLDS_STRING (value)' failed

(xfsettingsd:2468133): GLib-GObject-CRITICAL **: 16:18:50.545: g_value_get_string: assertion 'G_VALUE_HOLDS_STRING (value)' failed
xfsettingsd: No window manager registered on screen 0.

And then further down:

Generating connection YAML file...
Cleaning up...
Killing Xvnc process ID 2468093
+ xfce4-panel --sm-client-disable
Unable to init server: Could not connect: Connection refused
xfce4-panel: Cannot open display: .
Type "xfce4-panel --help" for usage.

So there’s an error to start on. So we can at least see what is now causing OOD to not work as expected.

I am not sure reading this what is immediately wrong and will have to look into this a bit more to understand why those errors are happening.

Further up I’m also seeing this:

Desktop 'TurboVNC: p-ic-4001:7 (ros5549)' started on display p-ic-4001:7

So it looks like the display using the window manager is not the one being connected to, which is given as screen 0 at the bottom.

When I look at the output file of a currently running comsol interactive the end does not have these lines:

Cleaning up...
Killing Xvnc process ID 2468093
+ xfce4-panel --sm-client-disable
Unable to init server: Could not connect: Connection refused
xfce4-panel: Cannot open display: .
Type "xfce4-panel --help" for usage.

But it does still have the

xfsettingsd: No window manager registered on screen 0

I only get those end lines when I click file/exit in comsol.

What happens if you follow these instructions and try to launch again:

Xvnc did not appear to shut down cleanly. Removing /tmp/.X11-unix/X7
Xvnc did not appear to shut down cleanly. Removing /tmp/.X7-lock

Mainly, are those files actually being removed?

They are owned by other users

[ros5549@p-ic-4001 tmp]$ ls -la .X*
-r–r–r-- 1 gbs35 gbs35 11 Jan 30 10:20 .X10-lock
-r–r–r-- 1 rqw5420 rqw5420 11 Jan 31 19:47 .X11-lock
-r–r–r-- 1 cmh7013 cmh7013 11 Jan 30 15:06 .X12-lock
-r–r–r-- 1 lab396 lab396 11 Jan 30 16:04 .X1-lock
-r–r–r-- 1 bjz16 bjz16 11 Jan 25 09:02 .X2-lock
-r–r–r-- 1 rzt5336 rzt5336 11 Jan 24 13:45 .X3-lock
-r–r–r-- 1 rug262 rug262 11 Jan 30 15:26 .X4-lock
-r–r–r-- 1 gip5038 gip5038 11 Jan 22 12:17 .X5-lock
-r–r–r-- 1 ece5034 ece5034 11 Jan 29 15:32 .X6-lock
-r–r–r-- 1 aud440 aud440 11 Jan 30 18:40 .X7-lock
-r–r–r-- 1 ijj5060 ijj5060 11 Jan 24 14:33 .X8-lock
-r–r–r-- 1 bcy5048 bcy5048 11 Jan 31 22:46 .X9-lock

I’m zeroing in on this message in particular:

xfsettingsd: No window manager registered on screen 0

Nothing is coming up so far that is obvious to me, but this seems likely as the problem. We have the wm starting but then not being what is connected to. I don’t know why that would be happening off the top of my head though. I’ll look into this more on my end and check back soon.