Problems with some applications inside of TurboVNC

A quick question if anyone has any tips on this.

I have run into a few GUI programs that have issues with redrawing and resizing in the TurboVNC session inside of the Interactive App browser window. Namely, Ansys Electronics Desktop, which runs via Mono (a Windows emulator for Linux), and IDV (, which runs through Java. So common theme here seems to be that these programs use less common ways to run the graphical environment.


We do have Troubleshooting Interactive Apps — Open OnDemand 1.8.12 documentation that describes properly configuring a window manager to help with resizing. However, I’m not sure if this addresses the problems you see.

Thanks Eric, we are using those settings, and resizing works for most applications, except those built with Mono ( - Ansys Electronic Desktop and Java - IDV.

I am mainly wondering if anyone has seen this.

It seems to me like an issue of the Window manager, and/or TurboVNC with those programs, I see similar issues with IDV when I run XFCE or Mate under FastX2, but not with NoMachine NX. Also, KDE seems to work OK with FastX2. I’ll experiment with the desktop managers some more and perhaps come up with a workable solution.

Eric, have you tried KDE or Gnome for desktop manager, and if you did, what would be the configuration for them?

I tried the XFCE, Mate and Fluxbox with the IDV (the Java based program), with all not redrawing right, but since it seems to work OK with KDE under FastX2, it’d be interesting to see what KDE does under the OOD/TurboVNC.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.