CentOS 7.7 installation issues through RPM

Hi All,

I have spent quite a few hours trying to troubleshoot this issue that I’ve had right off a fresh installation via the “Install Software from RPM” instructions on the osc.github.io site. I’ve even done a clean removal following the steps from a previous post on this forum.

After the install I put in my hosts name into the browser and it loaded into an error page,
that wasn’t too descriptive, and I wasn’t able to find how to activate Phusion Passenger to run with environment set to development and/or with the friendly error pages option set to on. so I was able to look at the logs in /var/log.

I tried searching for solutions based off of using,

Could not spawn process for application /var/www/ood/apps/sys/dashboard: An operating system error occurred while preparing to spawn an application process: Cannot create FIFO file /tmp/passenger.spawn.XXXXfPqCc2/response/finish: Permission denied (errno=13)
Error ID: 542ca4bf
Error details saved to: /tmp/passenger-error-9jHDwi.html

in my search terms and wasn’t able to find any solutions. Checked /tmp’s permissions, drwxrwxrwt. 11 root root 4096 Jan 15 19:28 tmp

Anything to help out would be fantastic,
Thanks All!

Hi and welcome!

What does that html say (/tmp/passenger-error-9jHDwi.html)? Can you post that here (removing anything you need)?

If I had to guess, it may be something about su permissons and not file permissions. Or rather that it can’t create a file as another user.

Are you blocking sudoers rules on your machines? We create a file like this:

[jeff@84eb04e64687 /]$ sudo cat /etc/sudoers.d/ood
Defaults:apache !requiretty, !authenticate 
Defaults:apache env_keep += "NGINX_STAGE_* OOD_*" 
apache ALL=(ALL) NOPASSWD: /opt/ood/nginx_stage/sbin/nginx_stage

That’s my guess off the top. If it isn’t that directly, that FIFO file creation is probably a red herring and not the actual problem just one it’s spitting out.

Just for reference I caught that directory in creation and it is attributed to me.
drwx------. 5 jeff jeff 4096 Jan 16 14:35 passenger.spawn.XXXXvNhhvu

Interesting enough there was no /tmp/passenger-error-9jHDwi.html in the directory but there were a handful of others that seemed to have the same info and be duplicates. They looked like they were displaying similar info to the /var/log if it wasn’t “garbly gook” script text.

screenshot 1



There was no,

Defaults:apache env_keep += “NGINX_STAGE_* OOD_*”

in /etc/sudoers.d/ood so I went ahead and added that.

OK. It’s either an issue of resources or permissions. You’re ulimits look fine and you have enough RAM. So maybe it’s an selinux thing? I’m fairly sure we have to disable it in 1.6.20 (we had a beta se-linux you can try ondemand-selinux but you may find it has limited success). In the 1.7.x release we’ll have better support for it.

Hmmm…Ok. I tried installing ondemand-selinux but still saw the error page from it crashing. I could look into it being a resource or permissions issue but don’t have any real firm/confident paths/routes to go down. These were the new logs in /var/log and the new HTML file screenshots,

/var/log #1

/var/log #2



The only different error I could really see was,
Could not spawn process for application /var/www/ood/apps/sys/dashboard: The application encountered the following error: uninitialized constant JobStatus (NameError)
Error ID: 49489782
Error details saved to: /tmp/passenger-error-pIfA7X.html

Looks like you did actually progress. You can see that message about Passenger Core online then it broke, whereas now you’re moving past it.

So you did make progress, so I think it was an selinux issue. Longterm, the selinux support for 1.6 was beta, so it could be a little faulty moving forward.

Now your current problem: That file /var/www/ood/apps/sys/dashboard/config/initializers/secret_token.rb doesn’t come with the base install. Looks like you’re trying to use some class JobStatus and ruby can’t find/load it.

I don’t know what this file is, or is trying to do - so I can’t help you with it (yet). You say you’re coming from a fresh install, so … I’m not sure. I went looking through old source files and couldn’t find it, though I just checked random tags.

Did you create that file? Can you check the timestamps to see if is the same time as all the other files in that directory?

@crbianchi did you move/change or figure out what that file was? Were you able to make progress?

Hi @jeff.ohrstrom, I actually haven’t gotten around to the issue again until today! As it turns out deleting /var/www/ood/apps/sys/dashboard/config/initializers/secret_token.rb was the magic solution that got me to the dashboard!

For reference here was the permission and dates of the secret_token.rb with everything else in the directory,

Screen Shot 2020-01-27 at 17.47.06

Now I am using Safari Version 13.0.4 (15608. to access Open OnDemand’s web interface. It shows this error message on the dashboard page,

I’m not sure which level of authentication is required, or whether using Shibboleth or OpenID Connect would really fix the situation since it claims it’s not currently configured for Safari. For authentication I was planning on using LDAP if it makes any difference. Regardless it said to report and I shall!

Thanks for your help so far! Glad I got to a way-more-functional dashboard page!

See https://osc.github.io/ood-documentation/master/customization.html?highlight=safari#disable-safari-warning-on-dashboard to disable the Safari warning as long as you are using a different authentication mechanism than basic auth.