Error when attempting to start interactive desktop session

Following the documentation, I have gone through the steps to set up interactive desktops. When I try to run the interactive desktop, it fails with the following error in output logs:

output.log

Setting VNC password...
Starting VNC server...
Could not start Xvnc.

Unrecognized option: -nohttpd
use: X [:<display>] [option]

vnc.log

Unrecognized option: -nohttpd
use: X [:<display>] [option]

Node OS: RHEL 7.9
TurboVNC: 2.2.90
Desktop environment: Xfce 4
OnDemand: 1.8.20

Issue was caused by the TurboVNC version. Downgrading TurboVNC to version 2.2.7 resolved the issue.

Sorry, yes we have a bug open on our side for the same. We’ll try to get this patched in 2.1, the next release.